summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-12-14 18:52:33 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-12-14 18:52:33 +0000
commitf37fff26a2e48d81ccd3ac03da8e64f8c21d4e4c (patch)
treefdfa5f9d7aef91abeae713bb74d0ad97c3be62b7 /dev-python/python-poppler
parentStable for AMD64, wrt bug #392391 (diff)
downloadgentoo-2-f37fff26a2e48d81ccd3ac03da8e64f8c21d4e4c.tar.gz
gentoo-2-f37fff26a2e48d81ccd3ac03da8e64f8c21d4e4c.tar.bz2
gentoo-2-f37fff26a2e48d81ccd3ac03da8e64f8c21d4e4c.zip
Removed patch python-poppler-0.12.1-76_75.diff to fix bug #390607. Thanks to quantumsummers.
(Portage version: 2.2.0_alpha46/cvs/Linux i686)
Diffstat (limited to 'dev-python/python-poppler')
-rw-r--r--dev-python/python-poppler/ChangeLog9
-rw-r--r--dev-python/python-poppler/python-poppler-0.12.1-r2.ebuild51
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/python-poppler/ChangeLog b/dev-python/python-poppler/ChangeLog
index e8fd888a8f2f..2ca9baa93330 100644
--- a/dev-python/python-poppler/ChangeLog
+++ b/dev-python/python-poppler/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-poppler
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/ChangeLog,v 1.16 2011/11/08 12:05:50 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/ChangeLog,v 1.17 2011/12/14 18:52:33 neurogeek Exp $
+
+*python-poppler-0.12.1-r2 (14 Dec 2011)
+
+ 14 Dec 2011; Jesus Rivero <neurogeek@gentoo.org>
+ +python-poppler-0.12.1-r2.ebuild:
+ Removed patch python-poppler-0.12.1-76_75.diff to fix bug #390607. Thanks
+ to quantumsummers.
08 Nov 2011; Naohiro Aota <naota@gentoo.org> python-poppler-0.12.1-r1.ebuild:
Add ~x86-fbsd
diff --git a/dev-python/python-poppler/python-poppler-0.12.1-r2.ebuild b/dev-python/python-poppler/python-poppler-0.12.1-r2.ebuild
new file mode 100644
index 000000000000..ba7431afe123
--- /dev/null
+++ b/dev-python/python-poppler/python-poppler-0.12.1-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/python-poppler-0.12.1-r2.ebuild,v 1.1 2011/12/14 18:52:33 neurogeek Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit eutils libtool python
+
+DESCRIPTION="Python bindings to the Poppler PDF library"
+HOMEPAGE="http://launchpad.net/poppler-python"
+SRC_URI="http://launchpad.net/poppler-python/trunk/development/+download/pypoppler-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="examples"
+
+S=${WORKDIR}/pypoppler-${PV}
+
+RDEPEND=">=app-text/poppler-0.15.0[cairo]
+ >=dev-python/pycairo-1.8.4
+ dev-python/pygobject:2
+ dev-python/pygtk:2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # http://pkgs.fedoraproject.org/gitweb/?p=pypoppler.git;a=tree
+ epatch \
+ "${FILESDIR}"/${P}-75_74.diff \
+ "${FILESDIR}"/${P}-79_78.diff \
+ "${FILESDIR}"/${P}-poppler0.15.0-changes.patch
+
+ elibtoolize
+ python_copy_sources
+}
+
+src_install() {
+ python_src_install
+ python_clean_installation_image
+
+ dodoc NEWS || die
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demo/demo-poppler.py || die
+ fi
+}