summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-03 13:59:02 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-03 13:59:02 +0000
commit79d9d66ebbf45a6f0e7b07ea7c64ec75191aeb80 (patch)
treebfc107cf7275a3da92b34a21f5f5e65178597c33 /dev-python/python-poppler
parentFixed dependency, bug #283558. (diff)
downloadgentoo-2-79d9d66ebbf45a6f0e7b07ea7c64ec75191aeb80.tar.gz
gentoo-2-79d9d66ebbf45a6f0e7b07ea7c64ec75191aeb80.tar.bz2
gentoo-2-79d9d66ebbf45a6f0e7b07ea7c64ec75191aeb80.zip
Bump to 0.10.1. Fixes #282940. Small ebuild fixes by Chris Mayo.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-poppler')
-rw-r--r--dev-python/python-poppler/ChangeLog8
-rw-r--r--dev-python/python-poppler/python-poppler-0.10.1.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/python-poppler/ChangeLog b/dev-python/python-poppler/ChangeLog
index ebb702e0fda3..4f1237ee00b3 100644
--- a/dev-python/python-poppler/ChangeLog
+++ b/dev-python/python-poppler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-poppler
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/ChangeLog,v 1.1 2009/06/01 13:58:47 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/ChangeLog,v 1.2 2009/09/03 13:59:02 patrick Exp $
+
+*python-poppler-0.10.1 (03 Sep 2009)
+
+ 03 Sep 2009; Patrick Lauer <patrick@gentoo.org>
+ +python-poppler-0.10.1.ebuild:
+ Bump to 0.10.1. Fixes #282940. Small ebuild fixes by Chris Mayo.
*python-poppler-0.10.0 (01 Jun 2009)
diff --git a/dev-python/python-poppler/python-poppler-0.10.1.ebuild b/dev-python/python-poppler/python-poppler-0.10.1.ebuild
new file mode 100644
index 000000000000..a02827923e94
--- /dev/null
+++ b/dev-python/python-poppler/python-poppler-0.10.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/python-poppler-0.10.1.ebuild,v 1.1 2009/09/03 13:59:02 patrick Exp $
+
+EAPI=2
+
+inherit libtool
+
+DESCRIPTION="Python bindings to the Poppler PDF library."
+SRC_URI="http://launchpad.net/poppler-python/trunk/development/+download/pypoppler-${PV}.tar.gz"
+HOMEPAGE="http://launchpad.net/poppler-python"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples"
+
+S="${WORKDIR}/pypoppler-${PV}"
+
+RDEPEND=">=virtual/poppler-glib-0.10.0
+ >=dev-python/pygobject-2.11.3
+ >=dev-python/pygtk-2.10.0
+ >=dev-python/pycairo-1.8.4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -type f -exec rm -f '{}' ';' || die "Removing .la files failed"
+ dodoc NEWS
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demo/demo-poppler.py
+ fi
+}