summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2008-07-10 10:13:09 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2008-07-10 10:13:09 +0000
commitc64f4822fb2297d8365d238ca86524363bc2f4ad (patch)
tree5f8f033e7fc428cf016a284842cfb39a017e636e /dev-python/python-ldap
parentia64/sparc/x86 stable wrt #230956 (diff)
downloadgentoo-2-c64f4822fb2297d8365d238ca86524363bc2f4ad.tar.gz
gentoo-2-c64f4822fb2297d8365d238ca86524363bc2f4ad.tar.bz2
gentoo-2-c64f4822fb2297d8365d238ca86524363bc2f4ad.zip
Version bump, see bug #231378.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-tuxonice-r6 x86_64)
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/ChangeLog10
-rw-r--r--dev-python/python-ldap/python-ldap-2.3.5.ebuild58
2 files changed, 66 insertions, 2 deletions
diff --git a/dev-python/python-ldap/ChangeLog b/dev-python/python-ldap/ChangeLog
index d27029299fa5..765ad43d791f 100644
--- a/dev-python/python-ldap/ChangeLog
+++ b/dev-python/python-ldap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-ldap
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.56 2007/08/15 11:12:27 dev-zero Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.57 2008/07/10 10:13:09 nelchael Exp $
+
+*python-ldap-2.3.5 (10 Jul 2008)
+
+ 10 Jul 2008; Krzysiek Pawlik <nelchael@gentoo.org>
+ +python-ldap-2.3.5.ebuild:
+ Version bump, see bug #231378.
*python-ldap-2.3.1 (15 Aug 2007)
diff --git a/dev-python/python-ldap/python-ldap-2.3.5.ebuild b/dev-python/python-ldap/python-ldap-2.3.5.ebuild
new file mode 100644
index 000000000000..34fb9a2e331b
--- /dev/null
+++ b/dev-python/python-ldap/python-ldap-2.3.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-2.3.5.ebuild,v 1.1 2008/07/10 10:13:09 nelchael Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils multilib
+
+P_DOC="html-${PN}-docs-2.0.3"
+
+DESCRIPTION="Various LDAP-related Python modules"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/${P_DOC}.tar.gz )"
+HOMEPAGE="http://python-ldap.sourceforge.net/"
+SLOT="0"
+LICENSE="PYTHON"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples sasl ssl"
+
+RDEPEND=">=net-nds/openldap-2.3
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="${DEPEND}
+ dev-python/setuptools"
+
+# Installs some script-files directly in site-packages
+PYTHON_MODNAME="/"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Note: we can't add /usr/lib and /usr/lib/sasl2 to library_dirs due to a bug in py2.4
+ sed -e "s:^library_dirs =.*:library_dirs =:" \
+ -e "s:^include_dirs =.*:include_dirs = /usr/include /usr/include/sasl:" \
+ -e "s:\(extra_compile_args =\).*:\1\nextra_link_args = -Wl,-rpath=/usr/$(get_libdir) -Wl,-rpath=/usr/$(get_libdir)/sasl2:" \
+ -i setup.cfg || die "error fixing setup.cfg"
+
+ local mylibs="ldap"
+ if use sasl ; then
+ use ssl && mylibs="ldap_r"
+ mylibs="${mylibs} sasl2"
+ fi
+ use ssl && mylibs="${mylibs} ssl crypto"
+
+ sed -e "s:^libs = .*:libs = lber resolv ${mylibs}:" \
+ -e "s:^compile.*:compile = 0:" \
+ -e "s:^optimize.*:optimize = 0:" \
+ -i setup.cfg || die "error setting up libs in setup.cfg"
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r "${WORKDIR}/${P_DOC/html-/}"/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r Demo
+ fi
+}