summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-06-03 06:18:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-06-03 06:18:37 +0000
commit5b934aecba7a19d68cf09f4c17e35031444f8439 (patch)
tree1b2a609d9862e5bf875c66e0d1a0eddae6a1ff57 /dev-python/python-ldap
parentAdd test dep on beautifulsoup (diff)
downloadgentoo-2-5b934aecba7a19d68cf09f4c17e35031444f8439.tar.gz
gentoo-2-5b934aecba7a19d68cf09f4c17e35031444f8439.tar.bz2
gentoo-2-5b934aecba7a19d68cf09f4c17e35031444f8439.zip
Bump
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/ChangeLog7
-rw-r--r--dev-python/python-ldap/python-ldap-2.4.12.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-python/python-ldap/ChangeLog b/dev-python/python-ldap/ChangeLog
index 8c7feb2fba20..29fdc2bb7160 100644
--- a/dev-python/python-ldap/ChangeLog
+++ b/dev-python/python-ldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-ldap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.123 2013/04/06 00:50:31 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.124 2013/06/03 06:18:37 patrick Exp $
+
+*python-ldap-2.4.12 (03 Jun 2013)
+
+ 03 Jun 2013; Patrick Lauer <patrick@gentoo.org> +python-ldap-2.4.12.ebuild:
+ Bump
06 Apr 2013; Naohiro Aota <naota@gentoo.org> python-ldap-2.4.10-r1.ebuild:
Add ~x86-fbsd.
diff --git a/dev-python/python-ldap/python-ldap-2.4.12.ebuild b/dev-python/python-ldap/python-ldap-2.4.12.ebuild
new file mode 100644
index 000000000000..c7c1d01625b1
--- /dev/null
+++ b/dev-python/python-ldap/python-ldap-2.4.12.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-2.4.12.ebuild,v 1.1 2013/06/03 06:18:37 patrick Exp $
+
+EAPI=5
+
+# pypy: bug #458558 (wrong linker options due to not respecting CC)
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1 multilib
+
+DESCRIPTION="Various LDAP-related Python modules"
+HOMEPAGE="http://www.python-ldap.org http://pypi.python.org/pypi/python-ldap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+IUSE="doc examples sasl ssl"
+
+# If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
+# python team: Please do not remove python-ldap-2.3.9 from the tree.
+RDEPEND=">=net-nds/openldap-2.4
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -e "s:^library_dirs =.*:library_dirs = /usr/$(get_libdir) /usr/$(get_libdir)/sasl2:" \
+ -e "s:^include_dirs =.*:include_dirs = ${EPREFIX}/usr/include ${EPREFIX}/usr/include/sasl:" \
+ -i setup.cfg || die "error fixing setup.cfg"
+
+ local mylibs="ldap"
+ if use sasl; then
+ use ssl && mylibs="ldap_r"
+ mylibs="${mylibs} sasl2"
+ else
+ sed -e 's/HAVE_SASL//g' -i setup.cfg || die
+ fi
+ use ssl && mylibs="${mylibs} ssl crypto"
+ use elibc_glibc && mylibs="${mylibs} resolv"
+
+ sed -e "s:^libs = .*:libs = lber ${mylibs}:" \
+ -i setup.cfg || die "error setting up libs in setup.cfg"
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ cd Doc || die
+ sphinx-build -b html -d _build/doctrees . _build/html || die
+ fi
+}
+
+python_test() {
+ # XXX: the tests supposedly can start local slapd
+ # but it requires some manual config, it seems.
+
+ "${PYTHON}" Tests/t_ldapurl.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/_build/html/. )
+
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r Demo
+ docompress -x /usr/share/doc/${FP}/Demo
+ fi
+}