summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-08-21 13:44:03 +0000
committerJustin Lecher <jlec@gentoo.org>2013-08-21 13:44:03 +0000
commit12474cf8689c5e8acbafa78b78e91873915ade64 (patch)
tree873a510852ddc863f04fa0f90efc59c2aeb7cfbe /dev-python/python-geoclue
parentx86 stable wrt bug #481522 (diff)
downloadgentoo-2-12474cf8689c5e8acbafa78b78e91873915ade64.tar.gz
gentoo-2-12474cf8689c5e8acbafa78b78e91873915ade64.tar.bz2
gentoo-2-12474cf8689c5e8acbafa78b78e91873915ade64.zip
dev-python/python-geoclue: Only drop to serial build when testing
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/python-geoclue')
-rw-r--r--dev-python/python-geoclue/ChangeLog5
-rw-r--r--dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-python/python-geoclue/ChangeLog b/dev-python/python-geoclue/ChangeLog
index bff49a2f799d..92d5c060125c 100644
--- a/dev-python/python-geoclue/ChangeLog
+++ b/dev-python/python-geoclue/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/python-geoclue
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-geoclue/ChangeLog,v 1.11 2013/08/21 13:41:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-geoclue/ChangeLog,v 1.12 2013/08/21 13:44:03 jlec Exp $
+
+ 21 Aug 2013; Justin Lecher <jlec@gentoo.org> python-geoclue-0.1.0-r1.ebuild:
+ Only drop to serial build when testing
*python-geoclue-0.1.0-r1 (21 Aug 2013)
diff --git a/dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild b/dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild
index ffa69a336d5a..40388d27b12d 100644
--- a/dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild
+++ b/dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild,v 1.1 2013/08/21 13:41:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild,v 1.2 2013/08/21 13:44:03 jlec Exp $
EAPI=5
@@ -24,7 +24,10 @@ DEPEND="test? ( app-misc/geoclue )"
S="${WORKDIR}"/${PN}
-DISTUTILS_NO_PARALLEL_BUILD=true
+python_prepare_all() {
+ use test && DISTUTILS_NO_PARALLEL_BUILD=true
+ distutils-r1_python_prepare_all
+}
python_test() {
VIRTUALX_COMMAND="${PYTHON}"