summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-09-06 10:14:48 +0000
committerAlin Năstac <mrness@gentoo.org>2007-09-06 10:14:48 +0000
commit58c687d0c1b438c09e5030dee1ec56dffdf2d026 (patch)
tree709b4fc3d847d70aab4ffcddf3168dc125d6d4b5 /dev-python/python-gammu
parentStable on x86, security bug #191321. (diff)
downloadgentoo-2-58c687d0c1b438c09e5030dee1ec56dffdf2d026.tar.gz
gentoo-2-58c687d0c1b438c09e5030dee1ec56dffdf2d026.tar.bz2
gentoo-2-58c687d0c1b438c09e5030dee1ec56dffdf2d026.zip
Version bump; fix several buffer overflows (#191303).
(Portage version: 2.1.2.12)
Diffstat (limited to 'dev-python/python-gammu')
-rw-r--r--dev-python/python-gammu/ChangeLog8
-rw-r--r--dev-python/python-gammu/files/digest-python-gammu-0.223
-rw-r--r--dev-python/python-gammu/files/python-gammu-0.22-fixups.patch41
-rw-r--r--dev-python/python-gammu/python-gammu-0.22.ebuild34
4 files changed, 85 insertions, 1 deletions
diff --git a/dev-python/python-gammu/ChangeLog b/dev-python/python-gammu/ChangeLog
index ab779e140e1f..92a865c45668 100644
--- a/dev-python/python-gammu/ChangeLog
+++ b/dev-python/python-gammu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-gammu
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gammu/ChangeLog,v 1.31 2007/08/22 07:14:01 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gammu/ChangeLog,v 1.32 2007/09/06 10:14:48 mrness Exp $
+
+*python-gammu-0.22 (06 Sep 2007)
+
+ 06 Sep 2007; Alin Năstac <mrness@gentoo.org>
+ +files/python-gammu-0.22-fixups.patch, +python-gammu-0.22.ebuild:
+ Version bump; fix several buffer overflows (#191303).
22 Aug 2007; Christian Faulhammer <opfer@gentoo.org>
python-gammu-0.21.ebuild:
diff --git a/dev-python/python-gammu/files/digest-python-gammu-0.22 b/dev-python/python-gammu/files/digest-python-gammu-0.22
new file mode 100644
index 000000000000..fd839a417b61
--- /dev/null
+++ b/dev-python/python-gammu/files/digest-python-gammu-0.22
@@ -0,0 +1,3 @@
+MD5 93e7399c7c0a9e7d1a5d1f3dcd6a8236 python-gammu-0.22.tar.bz2 76248
+RMD160 1cdc232041dead0ea73dccb43eae0335b5b6694c python-gammu-0.22.tar.bz2 76248
+SHA256 f06b4f66155b8de727ca598c64cfd0dd42c2e86ae60fa09dbf14d8b4d2dcc3d6 python-gammu-0.22.tar.bz2 76248
diff --git a/dev-python/python-gammu/files/python-gammu-0.22-fixups.patch b/dev-python/python-gammu/files/python-gammu-0.22-fixups.patch
new file mode 100644
index 000000000000..3e7afd108079
--- /dev/null
+++ b/dev-python/python-gammu/files/python-gammu-0.22-fixups.patch
@@ -0,0 +1,41 @@
+diff -Nru python-gammu-0.22.orig/gammu.c python-gammu-0.22/gammu.c
+--- python-gammu-0.22.orig/gammu.c 2007-08-01 16:06:31.000000000 +0300
++++ python-gammu-0.22/gammu.c 2007-09-06 13:09:52.000000000 +0300
+@@ -819,7 +819,7 @@
+ static PyObject *
+ StateMachine_GetManufacturer(StateMachineObject *self, PyObject *args, PyObject *kwds) {
+ GSM_Error error;
+- char value[100];
++ char value[GSM_MAX_MANUFACTURER_LENGTH];
+
+ if (!PyArg_ParseTuple(args, ""))
+ return NULL;
+@@ -847,7 +847,7 @@
+ static PyObject *
+ StateMachine_GetModel(StateMachineObject *self, PyObject *args, PyObject *kwds) {
+ GSM_Error error;
+- char value[100];
++ char value[GSM_MAX_MODEL_LENGTH];
+
+ if (!PyArg_ParseTuple(args, ""))
+ return NULL;
+@@ -875,8 +875,8 @@
+ static PyObject *
+ StateMachine_GetFirmware(StateMachineObject *self, PyObject *args, PyObject *kwds) {
+ GSM_Error error;
+- char firmware[100];
+- char date[100];
++ char firmware[GSM_MAX_VERSION_LENGTH];
++ char date[GSM_MAX_VERSION_DATE_LENGTH];
+ double ver;
+
+ if (!PyArg_ParseTuple(args, ""))
+@@ -908,7 +908,7 @@
+ static PyObject *
+ StateMachine_GetIMEI(StateMachineObject *self, PyObject *args, PyObject *kwds) {
+ GSM_Error error;
+- char value[100];
++ char value[GSM_MAX_IMEI_LENGTH];
+
+ if (!PyArg_ParseTuple(args, ""))
+ return NULL;
diff --git a/dev-python/python-gammu/python-gammu-0.22.ebuild b/dev-python/python-gammu/python-gammu-0.22.ebuild
new file mode 100644
index 000000000000..bf1975f7a2cd
--- /dev/null
+++ b/dev-python/python-gammu/python-gammu-0.22.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gammu/python-gammu-0.22.ebuild,v 1.1 2007/09/06 10:14:48 mrness Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Python bindings for Gammu"
+HOMEPAGE="http://www.cihar.com/gammu/python/"
+SRC_URI="ftp://dl.cihar.com/python-gammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=app-mobilephone/gammu-1.13.0"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}"/${P}-fixups.patch
+}
+
+src_install() {
+ DOCS="AUTHORS NEWS"
+ distutils_src_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.py
+ insinto /usr/share/doc/${PF}/examples/data
+ doins examples/data/*
+}