summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-24 02:00:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-24 02:00:05 +0000
commit978f0508b739dcba308827e2d670c67395eb0647 (patch)
tree8988bf2608daee499d0d3750dc2b945349cb6f3f /dev-python/python-docs/python-docs-3.1.1.ebuild
parentUpdate calls to 'eselect python update'. (diff)
downloadgentoo-2-978f0508b739dcba308827e2d670c67395eb0647.tar.gz
gentoo-2-978f0508b739dcba308827e2d670c67395eb0647.tar.bz2
gentoo-2-978f0508b739dcba308827e2d670c67395eb0647.zip
Version bump.
(Portage version: 14134-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-docs/python-docs-3.1.1.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-3.1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-3.1.1.ebuild b/dev-python/python-docs/python-docs-3.1.1.ebuild
new file mode 100644
index 000000000000..849e74c11224
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.1.1.ebuild,v 1.1 2009/08/24 02:00:05 arfrever Exp $
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="3.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=app-admin/eselect-python-20090606"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${D}/usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+pkg_postinst() {
+ :
+# eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2
+}
+
+pkg_postrm() {
+# eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2
+
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${ROOT}etc/env.d/65python-docs"
+ fi
+}