summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-28 07:49:45 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-28 07:49:45 +0000
commit7a060a31f1be9ec4a8109fef78672027fcd92f5c (patch)
tree104607e659759fa80a1f0d2436ea067300efc13a /dev-python/pytest
parentrm 1.4.19 wrt Bug #494496 (diff)
downloadgentoo-2-7a060a31f1be9ec4a8109fef78672027fcd92f5c.tar.gz
gentoo-2-7a060a31f1be9ec4a8109fef78672027fcd92f5c.tar.bz2
gentoo-2-7a060a31f1be9ec4a8109fef78672027fcd92f5c.zip
Add dep sphinx for doc build, fixes Bug #493480
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog6
-rw-r--r--dev-python/pytest/pytest-2.3.4.ebuild7
-rw-r--r--dev-python/pytest/pytest-2.3.5.ebuild7
-rw-r--r--dev-python/pytest/pytest-2.4.2.ebuild6
-rw-r--r--dev-python/pytest/pytest-2.5.2.ebuild4
5 files changed, 18 insertions, 12 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index 235432981586..46704805c0fd 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.86 2014/02/01 06:15:49 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.87 2014/03/28 07:49:45 idella4 Exp $
+
+ 28 Mar 2014; Ian Delaney <idella4@gentoo.org> pytest-2.3.4.ebuild,
+ pytest-2.3.5.ebuild, pytest-2.4.2.ebuild, pytest-2.5.2.ebuild:
+ Add dep sphinx for doc build, fixes Bug #493480
*pytest-2.5.2 (01 Feb 2014)
diff --git a/dev-python/pytest/pytest-2.3.4.ebuild b/dev-python/pytest/pytest-2.3.4.ebuild
index 7546f36827f9..29e94044cfaa 100644
--- a/dev-python/pytest/pytest-2.3.4.ebuild
+++ b/dev-python/pytest/pytest-2.3.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.4.ebuild,v 1.19 2013/09/05 18:46:13 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.4.ebuild,v 1.20 2014/03/28 07:49:45 idella4 Exp $
EAPI="5"
@@ -21,7 +21,8 @@ PY_VER="1.4.12"
RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
DOCS=( CHANGELOG README.txt )
diff --git a/dev-python/pytest/pytest-2.3.5.ebuild b/dev-python/pytest/pytest-2.3.5.ebuild
index 2d979981cdce..993d3650966e 100644
--- a/dev-python/pytest/pytest-2.3.5.ebuild
+++ b/dev-python/pytest/pytest-2.3.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.5.ebuild,v 1.16 2013/10/22 14:21:56 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.5.ebuild,v 1.17 2014/03/28 07:49:45 idella4 Exp $
EAPI="5"
@@ -20,7 +20,8 @@ IUSE="doc test"
PY_VER="1.4.13"
RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
python_prepare_all() {
# Disable versioning of py.test script to avoid collision with
diff --git a/dev-python/pytest/pytest-2.4.2.ebuild b/dev-python/pytest/pytest-2.4.2.ebuild
index ecec4a516737..15ed13ce9cab 100644
--- a/dev-python/pytest/pytest-2.4.2.ebuild
+++ b/dev-python/pytest/pytest-2.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 1.7 2013/12/09 01:44:58 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 1.8 2014/03/28 07:49:45 idella4 Exp $
EAPI="5"
@@ -28,7 +28,7 @@ DEPEND="${RDEPEND}
dev-python/pexpect[$(python_gen_usedep python{2_6,2_7,3_2,3_3})]
dev-python/pyyaml[${PYTHON_USEDEP}]
)
-"
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
PATCHES=(
"${FILESDIR}/pytest-2.4.2-pexpect-3.0.patch"
diff --git a/dev-python/pytest/pytest-2.5.2.ebuild b/dev-python/pytest/pytest-2.5.2.ebuild
index 7d1fb99624ea..8d21bec286c8 100644
--- a/dev-python/pytest/pytest-2.5.2.ebuild
+++ b/dev-python/pytest/pytest-2.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild,v 1.1 2014/02/01 06:15:49 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild,v 1.2 2014/03/28 07:49:45 idella4 Exp $
EAPI="5"
@@ -28,7 +28,7 @@ DEPEND="${RDEPEND}
dev-python/pexpect[$(python_gen_usedep python{2_6,2_7,3_2,3_3})]
dev-python/pyyaml[${PYTHON_USEDEP}]
)
-"
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
python_prepare_all() {
# Disable versioning of py.test script to avoid collision with