summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-05-10 03:31:17 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-05-10 03:31:17 +0000
commit554c16a7ae3943563fb85085914637a9e7030fd4 (patch)
tree835549390acd644916b81a1e6ab4d4f43fd12b99 /dev-python/pytest
parentRemove old (diff)
downloadgentoo-2-554c16a7ae3943563fb85085914637a9e7030fd4.tar.gz
gentoo-2-554c16a7ae3943563fb85085914637a9e7030fd4.tar.bz2
gentoo-2-554c16a7ae3943563fb85085914637a9e7030fd4.zip
Bump, remove old, drop s390 keywords until py catches up
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog10
-rw-r--r--dev-python/pytest/pytest-2.0.2.ebuild44
-rw-r--r--dev-python/pytest/pytest-2.0.3.ebuild44
-rw-r--r--dev-python/pytest/pytest-2.1.1.ebuild47
-rw-r--r--dev-python/pytest/pytest-2.2.3.ebuild47
-rw-r--r--dev-python/pytest/pytest-2.2.4.ebuild47
-rw-r--r--dev-python/pytest/pytest-2.3.2-r1.ebuild65
-rw-r--r--dev-python/pytest/pytest-2.3.3.ebuild65
-rw-r--r--dev-python/pytest/pytest-2.3.5.ebuild (renamed from dev-python/pytest/pytest-2.3.3-r1.ebuild)15
9 files changed, 16 insertions, 368 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index 1918494bf918..c65a1376891a 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.62 2013/04/10 19:51:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.63 2013/05/10 03:31:17 patrick Exp $
+
+*pytest-2.3.5 (10 May 2013)
+
+ 10 May 2013; Patrick Lauer <patrick@gentoo.org> +pytest-2.3.5.ebuild,
+ -pytest-2.0.2.ebuild, -pytest-2.0.3.ebuild, -pytest-2.1.1.ebuild,
+ -pytest-2.2.3.ebuild, -pytest-2.2.4.ebuild, -pytest-2.3.2-r1.ebuild,
+ -pytest-2.3.3-r1.ebuild, -pytest-2.3.3.ebuild:
+ Bump, remove old, drop s390 keywords until py catches up
10 Apr 2013; Agostino Sarubbo <ago@gentoo.org> pytest-2.3.4.ebuild:
Stable for s390, wrt bug #458992
diff --git a/dev-python/pytest/pytest-2.0.2.ebuild b/dev-python/pytest/pytest-2.0.2.ebuild
deleted file mode 100644
index a43a2164c06b..000000000000
--- a/dev-python/pytest/pytest-2.0.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.0.2.ebuild,v 1.7 2011/06/27 15:20:20 ranger Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-RDEPEND=">=dev-python/py-1.4.1"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools"
-
-DOCS="CHANGELOG README.txt"
-PYTHON_MODNAME="pytest.py _pytest"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" "build-${PYTHON_ABI}/lib/pytest.py"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
-}
diff --git a/dev-python/pytest/pytest-2.0.3.ebuild b/dev-python/pytest/pytest-2.0.3.ebuild
deleted file mode 100644
index 45622d3538e0..000000000000
--- a/dev-python/pytest/pytest-2.0.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.0.3.ebuild,v 1.7 2011/10/06 17:46:30 jer Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-RDEPEND=">=dev-python/py-1.4.3"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools"
-
-DOCS="CHANGELOG README.txt"
-PYTHON_MODNAME="pytest.py _pytest"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" "build-${PYTHON_ABI}/lib/pytest.py"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
-}
diff --git a/dev-python/pytest/pytest-2.1.1.ebuild b/dev-python/pytest/pytest-2.1.1.ebuild
deleted file mode 100644
index 62f102fe0eeb..000000000000
--- a/dev-python/pytest/pytest-2.1.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.1.1.ebuild,v 1.1 2011/09/11 04:40:35 floppym Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-RDEPEND=">=dev-python/py-1.4.5"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools"
-
-DOCS="CHANGELOG README.txt"
-PYTHON_MODNAME="pytest.py _pytest"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" "build-${PYTHON_ABI}/lib/pytest.py"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
-
- # Bug 380275: Test suite pre-compiles modules
- python_clean_installation_image -q
-}
diff --git a/dev-python/pytest/pytest-2.2.3.ebuild b/dev-python/pytest/pytest-2.2.3.ebuild
deleted file mode 100644
index b017cd43b00b..000000000000
--- a/dev-python/pytest/pytest-2.2.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.2.3.ebuild,v 1.2 2012/05/12 20:13:22 aballier Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-RDEPEND=">=dev-python/py-1.4.7"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools"
-
-DOCS="CHANGELOG README.txt"
-PYTHON_MODNAME="pytest.py _pytest"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" "build-${PYTHON_ABI}/lib/pytest.py"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
-
- # Bug 380275: Test suite pre-compiles modules
- python_clean_installation_image -q
-}
diff --git a/dev-python/pytest/pytest-2.2.4.ebuild b/dev-python/pytest/pytest-2.2.4.ebuild
deleted file mode 100644
index 4d0ece3483de..000000000000
--- a/dev-python/pytest/pytest-2.2.4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.2.4.ebuild,v 1.1 2012/06/28 07:12:18 patrick Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-RDEPEND=">=dev-python/py-1.4.7"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools"
-
-DOCS="CHANGELOG README.txt"
-PYTHON_MODNAME="pytest.py _pytest"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" "build-${PYTHON_ABI}/lib/pytest.py"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
-
- # Bug 380275: Test suite pre-compiles modules
- python_clean_installation_image -q
-}
diff --git a/dev-python/pytest/pytest-2.3.2-r1.ebuild b/dev-python/pytest/pytest-2.3.2-r1.ebuild
deleted file mode 100644
index b4ce1ec5522b..000000000000
--- a/dev-python/pytest/pytest-2.3.2-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.2-r1.ebuild,v 1.2 2012/11/23 01:19:57 floppym Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.4.11"
-RDEPEND=">=dev-python/py-${PY_VER}"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools"
-
-DOCS="CHANGELOG README.txt"
-PYTHON_MODNAME="pytest.py _pytest"
-
-src_prepare() {
- # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
- distutils_src_prepare
-}
-
-src_compile() {
- distutils_src_compile
-
- dodocs() {
- if [[ "${PYTHON_ABI}" == "2.7" ]]; then
- mkdir doc/en/.build || die
- PYTHONPATH="${S}/doc:${S}/build-${PYTHON_ABI}"/lib emake -C doc/en html
- fi
- }
- use doc && python_execute_function dodocs
-}
-
-src_test() {
- testing() {
- local exit_status=0
- PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" build-${PYTHON_ABI}/lib/pytest.py || exit_status=1
- return $exit_status
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
-
- # Bug 380275: Test suite pre-compiles modules
- python_clean_installation_image -q
-
- use doc && dohtml -r doc/en/_build/html/
-}
diff --git a/dev-python/pytest/pytest-2.3.3.ebuild b/dev-python/pytest/pytest-2.3.3.ebuild
deleted file mode 100644
index 9180e6978cdc..000000000000
--- a/dev-python/pytest/pytest-2.3.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.3.ebuild,v 1.2 2012/11/23 01:19:57 floppym Exp $
-
-EAPI="4"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.4.12"
-RDEPEND=">=dev-python/py-${PY_VER}"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools"
-
-DOCS="CHANGELOG README.txt"
-PYTHON_MODNAME="pytest.py _pytest"
-
-src_prepare() {
- # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
- distutils_src_prepare
-}
-
-src_compile() {
- distutils_src_compile
-
- dodocs() {
- if [[ "${PYTHON_ABI}" == "2.7" ]]; then
- mkdir doc/en/.build || die
- PYTHONPATH="${S}/doc:${S}/build-${PYTHON_ABI}"/lib emake -C doc/en html
- fi
- }
- use doc && python_execute_function dodocs
-}
-
-src_test() {
- testing() {
- local exit_status=0
- PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" build-${PYTHON_ABI}/lib/pytest.py || exit_status=1
- return $exit_status
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
-
- # Bug 380275: Test suite pre-compiles modules
- python_clean_installation_image -q
-
- use doc && dohtml -r doc/en/_build/html/
-}
diff --git a/dev-python/pytest/pytest-2.3.3-r1.ebuild b/dev-python/pytest/pytest-2.3.5.ebuild
index b9b5dc37c17c..8164755681a9 100644
--- a/dev-python/pytest/pytest-2.3.3-r1.ebuild
+++ b/dev-python/pytest/pytest-2.3.5.ebuild
@@ -1,26 +1,25 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.3-r1.ebuild,v 1.2 2012/12/17 20:02:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.5.ebuild,v 1.1 2013/05/10 03:31:17 patrick Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} )
-inherit distutils-r1
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9,2_0} )
+inherit distutils-r1 eutils
DESCRIPTION="py.test: simple powerful testing with Python"
HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
+IUSE="doc test"
# When bumping, please check setup.py for the proper py version
-PY_VER="1.4.12"
+PY_VER="1.4.13"
RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]"
DOCS=( CHANGELOG README.txt )