summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-07-01 16:13:50 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-07-01 16:13:50 +0000
commitc3118248966fa97c6ae5bdcaee077e9fb87f60b6 (patch)
treea82af2630640a3a4207bbc5a28208df19b718bbe /dev-python/pytables
parentdev-python/pytables: Correct use of python eclass, #475062 (diff)
downloadgentoo-2-c3118248966fa97c6ae5bdcaee077e9fb87f60b6.tar.gz
gentoo-2-c3118248966fa97c6ae5bdcaee077e9fb87f60b6.tar.bz2
gentoo-2-c3118248966fa97c6ae5bdcaee077e9fb87f60b6.zip
Drop old
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 895192F9)
Diffstat (limited to 'dev-python/pytables')
-rw-r--r--dev-python/pytables/ChangeLog6
-rw-r--r--dev-python/pytables/pytables-2.4.0-r1.ebuild63
-rw-r--r--dev-python/pytables/pytables-2.4.0.ebuild67
3 files changed, 5 insertions, 131 deletions
diff --git a/dev-python/pytables/ChangeLog b/dev-python/pytables/ChangeLog
index 73a522a96218..4d6f3a6835f5 100644
--- a/dev-python/pytables/ChangeLog
+++ b/dev-python/pytables/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pytables
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.46 2013/07/01 15:32:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.47 2013/07/01 16:13:49 xarthisius Exp $
+
+ 01 Jul 2013; Kacper Kowalik <xarthisius@gentoo.org> -pytables-2.4.0-r1.ebuild,
+ -pytables-2.4.0.ebuild:
+ Drop old
01 Jul 2013; Justin Lecher <jlec@gentoo.org> pytables-2.4.0-r1.ebuild,
pytables-3.0.0.ebuild, metadata.xml:
diff --git a/dev-python/pytables/pytables-2.4.0-r1.ebuild b/dev-python/pytables/pytables-2.4.0-r1.ebuild
deleted file mode 100644
index f8fcfb391c67..000000000000
--- a/dev-python/pytables/pytables-2.4.0-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-2.4.0-r1.ebuild,v 1.2 2013/07/01 15:32:06 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-MY_PN=tables
-MY_P=${MY_PN}-${PV}
-
-inherit distutils-r1
-
-DESCRIPTION="A package for managing hierarchical datasets built on top of the HDF5 library"
-HOMEPAGE="http://www.pytables.org http://pypi.python.org/pypi/tables"
-SRC_URI="mirror://sourceforge/${PN}/${PV}/${MY_P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="BSD"
-IUSE="doc contrib examples"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- sci-libs/hdf5:=
- >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
- dev-python/numexpr[${PYTHON_USEDEP}]
- dev-libs/lzo:2
- app-arch/bzip2"
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_P}
-
-DOCS=( ANNOUNCE.txt RELEASE_NOTES.txt THANKS doc/usersguide-${PV}.pdf )
-
-python_prepare_all() {
- export HDF5_DIR="${EPREFIX}"/usr
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- ${PYTHON} tables/tests/test_all.py || die
-}
-
-python_install_all() {
- if use doc; then
- HTML_DOCS=( doc/html/. )
- DOCS+=( doc/scripts )
- fi
- distutils-r1_python_install_all
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-
- if use contrib; then
- insinto /usr/share/${PF}
- doins -r contrib
- fi
-}
diff --git a/dev-python/pytables/pytables-2.4.0.ebuild b/dev-python/pytables/pytables-2.4.0.ebuild
deleted file mode 100644
index 911cd02cd7da..000000000000
--- a/dev-python/pytables/pytables-2.4.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-2.4.0.ebuild,v 1.2 2013/02/28 10:04:29 xarthisius Exp $
-
-EAPI=5
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
-
-MY_PN=tables
-MY_P=${MY_PN}-${PV}
-
-inherit distutils
-
-DESCRIPTION="A package for managing hierarchical datasets built on top of the HDF5 library."
-HOMEPAGE="http://www.pytables.org http://pypi.python.org/pypi/tables"
-SRC_URI="mirror://sourceforge/${PN}/${PV}/${MY_P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="BSD"
-IUSE="doc contrib examples"
-
-RDEPEND="
- sci-libs/hdf5:=
- >=dev-python/numpy-1.6.0
- dev-python/numexpr
- dev-libs/lzo:2
- app-arch/bzip2"
-DEPEND="${RDEPEND}
- dev-python/cython"
-
-S=${WORKDIR}/${MY_P}
-
-DOCS="ANNOUNCE.txt RELEASE_NOTES.txt THANKS doc/usersguide-${PV}.pdf"
-
-src_compile() {
- export HDF5_DIR="${EPREFIX}"/usr
- distutils_src_compile
-}
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" tables/tests/test_all.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-
- pushd doc > /dev/null
- use doc && dohtml -r html/*
-
- insinto /usr/share/doc/${PF}
- doins -r scripts
- popd > /dev/null
-
- insinto /usr/share/${PF}
- use contrib && doins -r contrib
-}