summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-04 18:43:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-04 18:43:35 +0000
commitcdece44637cb4b2c2b39e1fd94b0766819e2ef3d (patch)
tree0480651fb75db2060a2f551053ae1e577ac38d0a /dev-python/pysvn
parentadd missing test to IUSE (diff)
downloadgentoo-2-cdece44637cb4b2c2b39e1fd94b0766819e2ef3d.tar.gz
gentoo-2-cdece44637cb4b2c2b39e1fd94b0766819e2ef3d.tar.bz2
gentoo-2-cdece44637cb4b2c2b39e1fd94b0766819e2ef3d.zip
Remove old
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/ChangeLog5
-rw-r--r--dev-python/pysvn/pysvn-1.6.3-r1.ebuild87
2 files changed, 4 insertions, 88 deletions
diff --git a/dev-python/pysvn/ChangeLog b/dev-python/pysvn/ChangeLog
index a9d066ca66b8..049889f163c2 100644
--- a/dev-python/pysvn/ChangeLog
+++ b/dev-python/pysvn/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pysvn
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.2 2009/06/21 10:32:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.3 2009/09/04 18:43:35 patrick Exp $
+
+ 04 Sep 2009; Patrick Lauer <patrick@gentoo.org> -pysvn-1.6.3-r1.ebuild:
+ Remove old
*pysvn-1.7.0 (21 Jun 2009)
diff --git a/dev-python/pysvn/pysvn-1.6.3-r1.ebuild b/dev-python/pysvn/pysvn-1.6.3-r1.ebuild
deleted file mode 100644
index 209472ee2a1b..000000000000
--- a/dev-python/pysvn/pysvn-1.6.3-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.6.3-r1.ebuild,v 1.1 2009/04/01 14:57:02 patrick Exp $
-
-inherit eutils python toolchain-funcs
-
-DESCRIPTION="Object-oriented python bindings for subversion"
-HOMEPAGE="http://pysvn.tigris.org/"
-SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
-
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc examples"
-
-DEPEND="dev-util/subversion"
-# >=dev-python/pycxx-5.5.0"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P}/Source"
-
-src_unpack() {
- python_version
-
- unpack ${A}
-
- # skip test test-06 if executed as root otherwise it will fail
- cd "${S/Source/}"
- epatch "${FILESDIR}/skip-root-test.patch"
-
- cd "${S}"
-
- # since pysvn-1.6.3: These sources are not compatible with python =< 2.5
- # run the backport command to fix
- if [[ $PYVER_MAJOR -eq 2 ]] && [[ $PYVER_MINOR -lt 6 ]]; then
- einfo "prepare sources for python prior 2.6"
- python setup.py backport || die "backport failed"
- fi
-
- # needed to generate the Makefile
- python setup.py configure || die "configure failed"
-
- # we want our CFLAGS as well
- sed -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
- -e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \
- -e "/^CCC=/s:g++:$(tc-getCXX):" \
- -e "/^CC=/s:gcc:$(tc-getCC):" \
- -i Makefile \
- || die "sed failed in Makefile"
-}
-
-src_test() {
- vecho ">>> Test phase [test]: ${CATEGORY}/${PF}"
- emake test || die "test-pysvn.so failed"
- emake -C ../Tests || die "test failed"
- vecho ">>> Test phase [none]: ${CATEGORY}/${PF}"
-}
-
-src_install() {
- local sitedir="$(python_get_sitedir)/${PN}"
-
- cd pysvn/
-
- exeinto ${sitedir}
- doexe _pysvn*.so || die "doexe failed"
- insinto ${sitedir}
- doins __init__.py || die "doins failed"
-
- cd ../
-
- if use doc; then
- dohtml -r ../Docs/ || die "dohtml failed"
- fi
-
- if use examples; then
- docinto examples
- dodoc ../Examples/Client/* || die "dodoc examples failed"
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize "$(python_get_sitedir)/${PN}"
-}
-
-pkg_postrm() {
- python_mod_cleanup "$(python_get_sitedir)/${PN}"
-}