summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-28 13:42:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-28 13:42:29 +0000
commit1eb43f8e80a3775845adbdba4130854bd60b2aac (patch)
tree1b42565eca86375903d52b4a2072294e13528556 /dev-python/pysvn
parentDon't use --no-link option of python_copy_sources(). (diff)
downloadgentoo-2-1eb43f8e80a3775845adbdba4130854bd60b2aac.tar.gz
gentoo-2-1eb43f8e80a3775845adbdba4130854bd60b2aac.tar.bz2
gentoo-2-1eb43f8e80a3775845adbdba4130854bd60b2aac.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/pysvn-1.7.1.ebuild102
1 files changed, 0 insertions, 102 deletions
diff --git a/dev-python/pysvn/pysvn-1.7.1.ebuild b/dev-python/pysvn/pysvn-1.7.1.ebuild
deleted file mode 100644
index ce9e6249f853..000000000000
--- a/dev-python/pysvn/pysvn-1.7.1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.1.ebuild,v 1.2 2009/11/07 20:10:08 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils multilib python toolchain-funcs
-
-DESCRIPTION="Object-oriented python bindings for subversion"
-HOMEPAGE="http://pysvn.tigris.org/"
-SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
-
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-freebsd ~ppc-macos"
-IUSE="doc examples"
-
-DEPEND="dev-util/subversion
- >=dev-python/pycxx-5.5.0"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # Skip test test-06 if executed as root to avoid failure.
- epatch "${FILESDIR}/${P}-skip_root_test.patch"
-
- epatch "${FILESDIR}/${PN}-1.7.0-darwin-freebsd.patch"
-
- # Don't use internal copy of dev-python/pycxx.
- rm -fr Import
-
- python_copy_sources --no-link
-
- preparation() {
- cd Source
- if has "${PYTHON_ABI}" 2.4 2.5; then
- "$(PYTHON)" setup.py backport || die "Backport failed"
- fi
- }
- python_execute_function -s preparation
-}
-
-src_configure() {
- configuration() {
- cd Source
- "$(PYTHON)" setup.py configure --apr-inc-dir="${EPREFIX}/usr/include/apr-1" --svn-root-dir="${EPREFIX}/usr" || die "Configuration failed with Python {PYTHON_ABI}"
-
- sed -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
- -e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \
- -e "/^CCC=/s:g++:$(tc-getCXX):" \
- -e "/^CC=/s:gcc:$(tc-getCC):" \
- -e "/^LDSHARED=/s:g++:$(tc-getCXX):" \
- -i Makefile \
- || die "sed failed in Makefile"
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- building() {
- cd Source
- emake
- }
- python_execute_function -s building
-}
-
-src_test() {
- testing() {
- cd Source
- emake test || die "test-pysvn.so failed with Python ${PYTHON_ABI}"
- emake -C ../Tests || die "Tests failed with Python ${PYTHON_ABI}"
- }
- python_execute_function -s testing
-}
-
-src_install() {
- installation() {
- cd Source/pysvn
- exeinto "$(python_get_sitedir)/pysvn"
- doexe _pysvn*$(get_modname) || die "doexe failed"
- insinto "$(python_get_sitedir)/pysvn"
- doins __init__.py || die "doins failed"
- }
- python_execute_function -s installation
-
- if use doc; then
- dohtml -r Docs/ || die "dohtml failed"
- fi
-
- if use examples; then
- docinto examples
- dodoc Examples/Client/* || die "dodoc examples failed"
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize pysvn
-}
-
-pkg_postrm() {
- python_mod_cleanup pysvn
-}