summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-05-04 17:38:51 +0000
committerMarien Zwart <marienz@gentoo.org>2006-05-04 17:38:51 +0000
commitf1e9ab6836ee6499f92687e746b912e938b0d2ba (patch)
treeb2de45536f3463a5af91821560ee235c7881d55d /dev-python/pysqlite
parentRemoving st_lim from maintainer, because he is no longer maintaining it (diff)
downloadgentoo-2-f1e9ab6836ee6499f92687e746b912e938b0d2ba.tar.gz
gentoo-2-f1e9ab6836ee6499f92687e746b912e938b0d2ba.tar.bz2
gentoo-2-f1e9ab6836ee6499f92687e746b912e938b0d2ba.zip
Version bump, closes bug #132258. Thanks to arj for reporting.
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'dev-python/pysqlite')
-rw-r--r--dev-python/pysqlite/ChangeLog7
-rw-r--r--dev-python/pysqlite/files/digest-pysqlite-2.2.23
-rw-r--r--dev-python/pysqlite/pysqlite-2.2.2.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/pysqlite/ChangeLog b/dev-python/pysqlite/ChangeLog
index 7ff551afe05b..c4ae38223cad 100644
--- a/dev-python/pysqlite/ChangeLog
+++ b/dev-python/pysqlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pysqlite
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/ChangeLog,v 1.51 2006/04/07 15:21:56 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/ChangeLog,v 1.52 2006/05/04 17:38:50 marienz Exp $
+
+*pysqlite-2.2.2 (04 May 2006)
+
+ 04 May 2006; Marien Zwart <marienz@gentoo.org> +pysqlite-2.2.2.ebuild:
+ Version bump, closes bug #132258. Thanks to arj for reporting.
*pysqlite-2.2.0 (07 Apr 2006)
diff --git a/dev-python/pysqlite/files/digest-pysqlite-2.2.2 b/dev-python/pysqlite/files/digest-pysqlite-2.2.2
new file mode 100644
index 000000000000..4363703edbec
--- /dev/null
+++ b/dev-python/pysqlite/files/digest-pysqlite-2.2.2
@@ -0,0 +1,3 @@
+MD5 3260547d3f11c85613b2de8ed529a4fc pysqlite-2.2.2.tar.gz 75176
+RMD160 e2e1f18072ce56d193c22b608ea237692bc56353 pysqlite-2.2.2.tar.gz 75176
+SHA256 76a82a6a45ae9c12c0409427765ae56c06d8dbb03321f21b8c4d7da48c7cd2b3 pysqlite-2.2.2.tar.gz 75176
diff --git a/dev-python/pysqlite/pysqlite-2.2.2.ebuild b/dev-python/pysqlite/pysqlite-2.2.2.ebuild
new file mode 100644
index 000000000000..5796f898f954
--- /dev/null
+++ b/dev-python/pysqlite/pysqlite-2.2.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-2.2.2.ebuild,v 1.1 2006/05/04 17:38:51 marienz Exp $
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for the local database Sqlite"
+SRC_URI="http://initd.org/pub/software/pysqlite/releases/${PV:0:3}/${PV}/pysqlite-${PV}.tar.gz"
+HOMEPAGE="http://initd.org/tracker/pysqlite/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+LICENSE="pysqlite"
+SLOT="2"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-db/sqlite-3.1"
+
+
+src_compile() {
+ if ! use doc; then
+ export NODOCS=1
+ fi
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ pushd doc
+
+ insinto /usr/share/doc/${PF}
+ doins -r code || die "code examples doins failed"
+
+ dohtml -r . || die "dohtml failed"
+
+ popd
+}
+
+src_test() {
+ cd build/lib*
+ # tests use this as a nonexistant file
+ addpredict /foo/bar
+ PYTHONPATH=. "${python}" -c \
+ "from pysqlite2.test import test;import sys;sys.exit(test())" \
+ || die "test failed"
+}