summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-06-22 15:15:00 +0000
committerMarien Zwart <marienz@gentoo.org>2006-06-22 15:15:00 +0000
commitbf30b78c47c37ed20f4779d74984abb3f4009913 (patch)
tree04e602ff93de56a5caf0d2816b7b425b8ab9b2cd /dev-python/pysqlite
parentMasking gcc-sparc64-4.1.1 since it can't build 2.4 kernels (diff)
downloadgentoo-2-bf30b78c47c37ed20f4779d74984abb3f4009913.tar.gz
gentoo-2-bf30b78c47c37ed20f4779d74984abb3f4009913.tar.bz2
gentoo-2-bf30b78c47c37ed20f4779d74984abb3f4009913.zip
Version bump.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'dev-python/pysqlite')
-rw-r--r--dev-python/pysqlite/ChangeLog7
-rw-r--r--dev-python/pysqlite/files/digest-pysqlite-2.3.13
-rw-r--r--dev-python/pysqlite/pysqlite-2.3.1.ebuild33
3 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/pysqlite/ChangeLog b/dev-python/pysqlite/ChangeLog
index fe6aa09ea115..d9bdeabea19c 100644
--- a/dev-python/pysqlite/ChangeLog
+++ b/dev-python/pysqlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pysqlite
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/ChangeLog,v 1.53 2006/05/27 19:59:27 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/ChangeLog,v 1.54 2006/06/22 15:15:00 marienz Exp $
+
+*pysqlite-2.3.1 (22 Jun 2006)
+
+ 22 Jun 2006; Marien Zwart <marienz@gentoo.org> +pysqlite-2.3.1.ebuild:
+ Version bump.
*pysqlite-2.2.2-r1 (27 May 2006)
diff --git a/dev-python/pysqlite/files/digest-pysqlite-2.3.1 b/dev-python/pysqlite/files/digest-pysqlite-2.3.1
new file mode 100644
index 000000000000..cecd1a15e4a2
--- /dev/null
+++ b/dev-python/pysqlite/files/digest-pysqlite-2.3.1
@@ -0,0 +1,3 @@
+MD5 0ca35ad1baa94f38fb08b9793f75cdd0 pysqlite-2.3.1.tar.gz 79441
+RMD160 a8a9d6ecbb6a6ea52cd83154bb319a6ca9f7618a pysqlite-2.3.1.tar.gz 79441
+SHA256 01fe8cd7ce20eeb972c17e38e854d726ace4fcf2610235825bd4ede9b36b4e1a pysqlite-2.3.1.tar.gz 79441
diff --git a/dev-python/pysqlite/pysqlite-2.3.1.ebuild b/dev-python/pysqlite/pysqlite-2.3.1.ebuild
new file mode 100644
index 000000000000..6f2c4b6f9128
--- /dev/null
+++ b/dev-python/pysqlite/pysqlite-2.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-2.3.1.ebuild,v 1.1 2006/06/22 15:15:00 marienz Exp $
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for the local database Sqlite"
+SRC_URI="http://initd.org/pub/software/pysqlite/releases/${PV:0:3}/${PV}/pysqlite-${PV}.tar.gz"
+HOMEPAGE="http://initd.org/tracker/pysqlite/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+LICENSE="pysqlite"
+SLOT="2"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-db/sqlite-3.1"
+
+src_install() {
+ distutils_src_install
+
+ mv "${D}"/usr/pysqlite2-doc/* "${D}"/usr/share/doc/${PF}
+ rm -rf "${D}"/usr/pysqlite2-doc
+}
+
+src_test() {
+ cd build/lib*
+ # tests use this as a nonexistant file
+ addpredict /foo/bar
+ PYTHONPATH=. "${python}" -c \
+ "from pysqlite2.test import test;import sys;sys.exit(test())" \
+ || die "test failed"
+}