summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-07-07 13:44:32 +0000
committerAli Polatel <hawking@gentoo.org>2007-07-07 13:44:32 +0000
commit6c9b1537e54549298ed01d846424d7f5a3a54d62 (patch)
tree14ef9532ff9aa64b2a4af36cca4555206528af71 /dev-python/pysqlite
parentAdded ~ppc (diff)
downloadgentoo-2-6c9b1537e54549298ed01d846424d7f5a3a54d62.tar.gz
gentoo-2-6c9b1537e54549298ed01d846424d7f5a3a54d62.tar.bz2
gentoo-2-6c9b1537e54549298ed01d846424d7f5a3a54d62.zip
revbump, fix encoding issues, use PYTHON_MODNAME, don't install tests
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'dev-python/pysqlite')
-rw-r--r--dev-python/pysqlite/ChangeLog7
-rw-r--r--dev-python/pysqlite/files/digest-pysqlite-2.3.4-r13
-rw-r--r--dev-python/pysqlite/pysqlite-2.3.4-r1.ebuild54
3 files changed, 63 insertions, 1 deletions
diff --git a/dev-python/pysqlite/ChangeLog b/dev-python/pysqlite/ChangeLog
index 6e193a3e70e1..82039255afcc 100644
--- a/dev-python/pysqlite/ChangeLog
+++ b/dev-python/pysqlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pysqlite
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/ChangeLog,v 1.74 2007/06/20 10:46:15 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/ChangeLog,v 1.75 2007/07/07 13:44:32 hawking Exp $
+
+*pysqlite-2.3.4-r1 (07 Jul 2007)
+
+ 07 Jul 2007; Ali Polatel <hawking@gentoo.org> +pysqlite-2.3.4-r1.ebuild:
+ revbump, fix encoding issues, use PYTHON_MODNAME, don't install tests
*pysqlite-2.3.4 (20 Jun 2007)
diff --git a/dev-python/pysqlite/files/digest-pysqlite-2.3.4-r1 b/dev-python/pysqlite/files/digest-pysqlite-2.3.4-r1
new file mode 100644
index 000000000000..bdf5a42cb26a
--- /dev/null
+++ b/dev-python/pysqlite/files/digest-pysqlite-2.3.4-r1
@@ -0,0 +1,3 @@
+MD5 0c0103a3cea1beebbd7d5ad7458f61e1 pysqlite-2.3.4.tar.gz 65240
+RMD160 1fdbb48e2af7b4ee26a932e930cce5016d7b73cb pysqlite-2.3.4.tar.gz 65240
+SHA256 743559c2ed64e465d7db46fb2d0932fb21e3a870ff3d761b2373dac624c96434 pysqlite-2.3.4.tar.gz 65240
diff --git a/dev-python/pysqlite/pysqlite-2.3.4-r1.ebuild b/dev-python/pysqlite/pysqlite-2.3.4-r1.ebuild
new file mode 100644
index 000000000000..1312d0e19bf6
--- /dev/null
+++ b/dev-python/pysqlite/pysqlite-2.3.4-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-2.3.4-r1.ebuild,v 1.1 2007/07/07 13:44:32 hawking Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for the local database Sqlite"
+SRC_URI="http://initd.org/pub/software/pysqlite/releases/${PV:0:3}/${PV}/pysqlite-${PV}.tar.gz"
+HOMEPAGE="http://initd.org/tracker/pysqlite/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+LICENSE="pysqlite"
+SLOT="2"
+IUSE="examples"
+
+DEPEND=">=dev-db/sqlite-3.1"
+
+PYTHON_MODNAME="pysqlite2"
+
+src_unpack() {
+ distutils_src_unpack
+ # don't install pysqlite2.test
+ sed -i -e 's/, "pysqlite2.test"//' \
+ setup.py || die "sed in setup.py failed"
+ # workaround to make checks work without installing them
+ sed -i -e "s/pysqlite2.test/test/" \
+ pysqlite2/test/__init__.py || die "sed failed"
+ # correct encoding
+ sed -i -e "s/\(coding: \)ISO-8859-1/\1utf-8/" \
+ pysqlite2/__init__.py pysqlite2/dbapi2.py || die "sed failed"
+}
+
+src_install() {
+ DOCS="doc/usage-guide.txt"
+ distutils_src_install
+
+ rm -rf "${D}"/usr/pysqlite2-doc
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/code
+ fi
+}
+
+src_test() {
+ cd pysqlite2
+ # tests use this as a nonexistant file
+ addpredict /foo/bar
+ PYTHONPATH="$(ls -d ../build/lib.*)" "${python}" -c \
+ "from test import test;import sys;sys.exit(test())" \
+ || die "test failed"
+}