summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-02 00:31:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-02 00:31:55 +0000
commit6211dc4a22a530fa8d9cda24bd95e38a2bed8234 (patch)
tree622af37d2b0d3282f29d332aa9b4c18ca0b49f90 /dev-python/pyrex
parentAdd missing echo and use $(get_python). (diff)
downloadgentoo-2-6211dc4a22a530fa8d9cda24bd95e38a2bed8234.tar.gz
gentoo-2-6211dc4a22a530fa8d9cda24bd95e38a2bed8234.tar.bz2
gentoo-2-6211dc4a22a530fa8d9cda24bd95e38a2bed8234.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 13874-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyrex')
-rw-r--r--dev-python/pyrex/ChangeLog10
-rw-r--r--dev-python/pyrex/pyrex-0.9.8.5-r1.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/pyrex/ChangeLog b/dev-python/pyrex/ChangeLog
index f9d5cc4ee7cd..9986f4c84907 100644
--- a/dev-python/pyrex/ChangeLog
+++ b/dev-python/pyrex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyrex
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrex/ChangeLog,v 1.72 2009/04/20 01:09:21 gentoofan23 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrex/ChangeLog,v 1.73 2009/08/02 00:31:55 arfrever Exp $
+
+*pyrex-0.9.8.5-r1 (02 Aug 2009)
+
+ 02 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pyrex-0.9.8.5-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
20 Apr 2009; Thomas Anderson <gentoofan23@gentoo.org>
pyrex-0.9.8.5.ebuild:
diff --git a/dev-python/pyrex/pyrex-0.9.8.5-r1.ebuild b/dev-python/pyrex/pyrex-0.9.8.5-r1.ebuild
new file mode 100644
index 000000000000..86a8b21afecf
--- /dev/null
+++ b/dev-python/pyrex/pyrex-0.9.8.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrex/pyrex-0.9.8.5-r1.ebuild,v 1.1 2009/08/02 00:31:55 arfrever Exp $
+
+EAPI="2"
+NEED_PYTHON=2.3
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+MY_P="Pyrex-${PV}"
+DESCRIPTION="A language for writing Python extension modules"
+HOMEPAGE="http://www.cosc.canterbury.ac.nz/~greg/python/Pyrex"
+SRC_URI="http://www.cosc.canterbury.ac.nz/~greg/python/Pyrex/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="Pyrex"
+
+# This version doesn't work with older setuptools #218815
+RDEPEND="!<dev-python/setuptools-0.6_rc8"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_install() {
+ DOCS="CHANGES.txt ToDo.txt USAGE.txt"
+ distutils_src_install
+
+ dohtml -A c -r Doc/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r Demos
+ fi
+}