summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-01-24 17:00:24 +0000
committerJeroen Roovers <jer@gentoo.org>2010-01-24 17:00:24 +0000
commitf00809122f806ba4a4ccb31fc64c4d945501d880 (patch)
tree0d1411c67164e166a27cd3d60ad9a8c31230285f /dev-python/pyparted
parentMask python3 for stable sys-apps/portage-2.1.7* until python-3.x is marked st... (diff)
downloadgentoo-2-f00809122f806ba4a4ccb31fc64c4d945501d880.tar.gz
gentoo-2-f00809122f806ba4a4ccb31fc64c4d945501d880.tar.bz2
gentoo-2-f00809122f806ba4a4ccb31fc64c4d945501d880.zip
Version bump (bug #300106).
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/ChangeLog7
-rw-r--r--dev-python/pyparted/pyparted-3.0.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
index bff18a2606cd..46f7a93a061f 100644
--- a/dev-python/pyparted/ChangeLog
+++ b/dev-python/pyparted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyparted
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.39 2010/01/07 20:53:53 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.40 2010/01/24 17:00:24 jer Exp $
+
+*pyparted-3.0 (24 Jan 2010)
+
+ 24 Jan 2010; Jeroen Roovers <jer@gentoo.org> +pyparted-3.0.ebuild:
+ Version bump (bug #300106).
*pyparted-1.8.9-r1 (07 Jan 2010)
diff --git a/dev-python/pyparted/pyparted-3.0.ebuild b/dev-python/pyparted/pyparted-3.0.ebuild
new file mode 100644
index 000000000000..556db1f8f9d8
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.0.ebuild,v 1.1 2010/01/24 17:00:24 jer Exp $
+
+EAPI="2"
+
+inherit multilib python
+
+DESCRIPTION="Python bindings for sys-apps/parted"
+HOMEPAGE="https://fedorahosted.org/pyparted/"
+SRC_URI="http://fedorahosted.org/releases/p/y/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ sys-libs/ncurses
+ >=dev-lang/python-2.4
+ >=sys-apps/parted-2.1
+ dev-python/decorator
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ python_need_rebuild
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog NEWS README TODO
+}