summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-03 01:22:50 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-03 01:22:50 +0000
commita9dcd7297a59ff9128b199367e396ce3ac7636ef (patch)
tree6f1638eb58cb8ddf9abefdc864e9d87bab8b1ac3 /dev-python/pyparted
parentNew library, bug 118656. Imported with cleanups from the sci overlay. (diff)
downloadgentoo-2-a9dcd7297a59ff9128b199367e396ce3ac7636ef.tar.gz
gentoo-2-a9dcd7297a59ff9128b199367e396ce3ac7636ef.tar.bz2
gentoo-2-a9dcd7297a59ff9128b199367e396ce3ac7636ef.zip
Set SUPPORT_PYTHON_ABIS, call python_mod_optimize() and python_mod_cleanup() (bug #345525).
(Portage version: 2.2.0_alpha26_p5/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/ChangeLog7
-rw-r--r--dev-python/pyparted/pyparted-3.4.ebuild36
-rw-r--r--dev-python/pyparted/pyparted-3.5.ebuild34
3 files changed, 55 insertions, 22 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
index e15d168b1b87..a942e44060ad 100644
--- a/dev-python/pyparted/ChangeLog
+++ b/dev-python/pyparted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyparted
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.58 2011/01/27 12:21:23 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.59 2011/03/03 01:22:50 arfrever Exp $
+
+ 03 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pyparted-3.4.ebuild, pyparted-3.5.ebuild:
+ Set SUPPORT_PYTHON_ABIS, call python_mod_optimize() and python_mod_cleanup()
+ (bug #345525).
*pyparted-3.5 (27 Jan 2011)
diff --git a/dev-python/pyparted/pyparted-3.4.ebuild b/dev-python/pyparted/pyparted-3.4.ebuild
index 9b86ddf9b054..912d9ef79d29 100644
--- a/dev-python/pyparted/pyparted-3.4.ebuild
+++ b/dev-python/pyparted/pyparted-3.4.ebuild
@@ -1,35 +1,49 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.4.ebuild,v 1.11 2010/10/29 18:46:37 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.4.ebuild,v 1.12 2011/03/03 01:22:50 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-inherit autotools multilib python
+inherit autotools python
DESCRIPTION="Python bindings for sys-block/parted"
HOMEPAGE="https://fedorahosted.org/pyparted/"
SRC_URI="https://fedorahosted.org/releases/p/y/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ~ppc64 sparc x86"
IUSE=""
-DEPEND="
- sys-libs/ncurses
- >=dev-lang/python-2.4
+DEPEND="dev-python/decorator
>=sys-block/parted-2.3
- dev-python/decorator
-"
+ sys-libs/ncurses"
RDEPEND="${DEPEND}"
src_prepare() {
sed -i -e 's/-avoid-version/& -shared /' src/Makefile.am || die "sed failed"
eautoreconf
+
+ # Disable byte-compilation of Python modules.
+ echo "#!/bin/sh" > py-compile
+
+ python_src_prepare
}
src_install() {
- python_need_rebuild
- emake DESTDIR="${D}" install || die "emake install failed"
+ python_src_install
python_clean_installation_image
dodoc ChangeLog NEWS README TODO
}
+
+pkg_postinst() {
+ python_mod_optimize parted
+}
+
+pkg_postrm() {
+ python_mod_cleanup parted
+}
diff --git a/dev-python/pyparted/pyparted-3.5.ebuild b/dev-python/pyparted/pyparted-3.5.ebuild
index bebf72088615..6d344d69d2db 100644
--- a/dev-python/pyparted/pyparted-3.5.ebuild
+++ b/dev-python/pyparted/pyparted-3.5.ebuild
@@ -1,35 +1,49 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.5.ebuild,v 1.1 2011/01/27 12:21:23 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.5.ebuild,v 1.2 2011/03/03 01:22:50 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-inherit autotools multilib python
+inherit autotools python
DESCRIPTION="Python bindings for sys-block/parted"
HOMEPAGE="https://fedorahosted.org/pyparted/"
SRC_URI="https://fedorahosted.org/releases/p/y/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
-DEPEND="
- sys-libs/ncurses
- >=dev-lang/python-2.4
+DEPEND="dev-python/decorator
>=sys-block/parted-2.3
- dev-python/decorator
-"
+ sys-libs/ncurses"
RDEPEND="${DEPEND}"
src_prepare() {
sed -i -e 's/-avoid-version/& -shared /' src/Makefile.am || die "sed failed"
eautoreconf
+
+ # Disable byte-compilation of Python modules.
+ echo "#!/bin/sh" > py-compile
+
+ python_src_prepare
}
src_install() {
- python_need_rebuild
- emake DESTDIR="${D}" install || die "emake install failed"
+ python_src_install
python_clean_installation_image
dodoc ChangeLog NEWS README TODO
}
+
+pkg_postinst() {
+ python_mod_optimize parted
+}
+
+pkg_postrm() {
+ python_mod_cleanup parted
+}