summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-12-31 18:00:19 +0000
committerJeroen Roovers <jer@gentoo.org>2012-12-31 18:00:19 +0000
commitcfb7e13b4556cdb39138ea4ea3a1654dd4d8589c (patch)
treeb493a377585e34ba2ccaff655a36d025a072666f /dev-python/pyparted/pyparted-3.9.ebuild
parentRemove p.u.mask for non-keyworded app-admin/packagekit-base. (diff)
downloadgentoo-2-cfb7e13b4556cdb39138ea4ea3a1654dd4d8589c.tar.gz
gentoo-2-cfb7e13b4556cdb39138ea4ea3a1654dd4d8589c.tar.bz2
gentoo-2-cfb7e13b4556cdb39138ea4ea3a1654dd4d8589c.zip
Version bump.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-python/pyparted/pyparted-3.9.ebuild')
-rw-r--r--dev-python/pyparted/pyparted-3.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyparted/pyparted-3.9.ebuild b/dev-python/pyparted/pyparted-3.9.ebuild
new file mode 100644
index 000000000000..0500f53d6f8c
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.9.ebuild,v 1.1 2012/12/31 18:00:19 jer Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.* *-jython 2.7-pypy-*"
+PYTHON_MODNAME="parted"
+
+inherit distutils
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://fedorahosted.org/pyparted/"
+SRC_URI="https://fedorahosted.org/releases/p/y/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/decorator
+ >=sys-block/parted-3.1
+ sys-libs/ncurses
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/pychecker )
+"