summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2006-09-11 18:32:33 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2006-09-11 18:32:33 +0000
commit9016e46b9d6f03d75924cf5b2f8d266cb57a0327 (patch)
treebedeaa19b89bd1098270f87d2ac0aa963c2aa28b /dev-python/pyorbit
parentFixed digest conflicts, #147171 (diff)
downloadgentoo-2-9016e46b9d6f03d75924cf5b2f8d266cb57a0327.tar.gz
gentoo-2-9016e46b9d6f03d75924cf5b2f8d266cb57a0327.tar.bz2
gentoo-2-9016e46b9d6f03d75924cf5b2f8d266cb57a0327.zip
Bump to 2.14.1
(Portage version: 2.1.1_rc1-r6)
Diffstat (limited to 'dev-python/pyorbit')
-rw-r--r--dev-python/pyorbit/ChangeLog7
-rw-r--r--dev-python/pyorbit/files/digest-pyorbit-2.14.13
-rw-r--r--dev-python/pyorbit/pyorbit-2.14.1.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/dev-python/pyorbit/ChangeLog b/dev-python/pyorbit/ChangeLog
index 418ad17728e8..6df4c6c49a39 100644
--- a/dev-python/pyorbit/ChangeLog
+++ b/dev-python/pyorbit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyorbit
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyorbit/ChangeLog,v 1.35 2006/08/16 15:10:47 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyorbit/ChangeLog,v 1.36 2006/09/11 18:32:33 dang Exp $
+
+*pyorbit-2.14.1 (11 Sep 2006)
+
+ 11 Sep 2006; Daniel Gryniewicz <dang@gentoo.org> +pyorbit-2.14.1.ebuild:
+ Bump to 2.14.1
16 Aug 2006; Markus Rothe <corsair@gentoo.org> pyorbit-2.14.0.ebuild:
Stable on ppc64
diff --git a/dev-python/pyorbit/files/digest-pyorbit-2.14.1 b/dev-python/pyorbit/files/digest-pyorbit-2.14.1
new file mode 100644
index 000000000000..a2af4347deba
--- /dev/null
+++ b/dev-python/pyorbit/files/digest-pyorbit-2.14.1
@@ -0,0 +1,3 @@
+MD5 a3728affed2aa878966f792ae171e0f0 pyorbit-2.14.1.tar.bz2 282603
+RMD160 1551c48156b18d34c639e83e1e745f354a1df6a8 pyorbit-2.14.1.tar.bz2 282603
+SHA256 7b241852373b02046125573fc6cf3b4e839bdc09881fdefbdcec9bb9332d6f62 pyorbit-2.14.1.tar.bz2 282603
diff --git a/dev-python/pyorbit/pyorbit-2.14.1.ebuild b/dev-python/pyorbit/pyorbit-2.14.1.ebuild
new file mode 100644
index 000000000000..3e7194a9bbd6
--- /dev/null
+++ b/dev-python/pyorbit/pyorbit-2.14.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyorbit/pyorbit-2.14.1.ebuild,v 1.1 2006/09/11 18:32:33 dang Exp $
+
+inherit python gnome2
+
+DESCRIPTION="ORBit2 bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.4
+ >=gnome-base/orbit-2.12"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS ChangeLog INSTALL NEWS README TODO"
+
+src_unpack() {
+
+ unpack ${A}
+ # disable pyc compiling
+ mv ${S}/py-compile ${S}/py-compile.orig
+ ln -s /bin/true ${S}/py-compile
+
+}
+
+src_install() {
+
+ gnome2_src_install
+
+ python_version
+ mv ${D}/usr/lib/python${PYVER}/site-packages/CORBA.py \
+ ${D}/usr/lib/python${PYVER}/site-packages/pyorbit_CORBA.py
+
+ mv ${D}/usr/lib/python${PYVER}/site-packages/PortableServer.py \
+ ${D}/usr/lib/python${PYVER}/site-packages/pyorbit_PortableServer.py
+
+}
+
+pkg_postinst() {
+
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages
+
+}
+
+pkg_postrm() {
+
+ python_version
+ python_mod_cleanup
+
+}