summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2010-02-08 11:40:43 +0000
committerMichael Januszewski <spock@gentoo.org>2010-02-08 11:40:43 +0000
commit60ad18840823b44c0f81603d30689a1f332111d8 (patch)
tree669542c7841276109bfd850e28960f5f22649ed7 /dev-python/pyopencl
parentMake system web browser plugins symlink optional, wrt bug #301911 by (diff)
downloadgentoo-2-60ad18840823b44c0f81603d30689a1f332111d8.tar.gz
gentoo-2-60ad18840823b44c0f81603d30689a1f332111d8.tar.bz2
gentoo-2-60ad18840823b44c0f81603d30689a1f332111d8.zip
Add a live git ebuild.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/ChangeLog7
-rw-r--r--dev-python/pyopencl/pyopencl-9999.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-python/pyopencl/ChangeLog b/dev-python/pyopencl/ChangeLog
index 1fb4f1b9dc12..3030ad8e24a6 100644
--- a/dev-python/pyopencl/ChangeLog
+++ b/dev-python/pyopencl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyopencl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/ChangeLog,v 1.1 2010/02/08 11:04:08 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/ChangeLog,v 1.2 2010/02/08 11:40:43 spock Exp $
+
+*pyopencl-9999 (08 Feb 2010)
+
+ 08 Feb 2010; Michał Januszewski <spock@gentoo.org> +pyopencl-9999.ebuild:
+ Add a live git ebuild.
*pyopencl-0.91.4 (08 Feb 2010)
diff --git a/dev-python/pyopencl/pyopencl-9999.ebuild b/dev-python/pyopencl/pyopencl-9999.ebuild
new file mode 100644
index 000000000000..7cf1ab9462e4
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-9999.ebuild,v 1.1 2010/02/08 11:40:43 spock Exp $
+# Ebuild generated by g-pypi 0.2.1 (rev. 204)
+
+EAPI="2"
+
+inherit git distutils
+
+EGIT_REPO_URI="http://git.tiker.net/trees/pyopencl.git"
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="http://mathema.tician.de/software/pyopencl"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="examples opengl"
+
+RDEPEND="dev-libs/boost[python]
+ =dev-python/pytools-9999
+ >=dev-python/numpy-1.0.4"
+
+DEPEND="${RDEPEND}"
+
+src_unpack()
+{
+ git_src_unpack
+}
+
+src_configure()
+{
+ if use opengl; then
+ myconf="${myconf} --cl-enable-gl"
+ fi
+
+ ./configure.py --boost-python-libname=boost_python-mt \
+ --boost-thread-libname=boost_thread-mt --boost-compiler=gcc \
+ ${myconf}
+}
+
+src_install()
+{
+ distutils_src_install
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ doins -r examples || die
+ fi
+}
+
+pkg_postinst()
+{
+ distutils_pkg_postinst
+ if use examples; then
+ elog "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+}