summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-14 22:52:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-14 22:52:00 +0000
commit9be34afeae54748c5f62224760b56f55bd467e8c (patch)
treeb92bee3adeed90bf41bb1c53251cee4200b8f763 /dev-python/pynut
parentI appreciate your quickness to commit this patch, but please do not ever drop... (diff)
downloadgentoo-2-9be34afeae54748c5f62224760b56f55bd467e8c.tar.gz
gentoo-2-9be34afeae54748c5f62224760b56f55bd467e8c.tar.bz2
gentoo-2-9be34afeae54748c5f62224760b56f55bd467e8c.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14820-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pynut')
-rw-r--r--dev-python/pynut/ChangeLog6
-rw-r--r--dev-python/pynut/pynut-1.1.ebuild27
2 files changed, 23 insertions, 10 deletions
diff --git a/dev-python/pynut/ChangeLog b/dev-python/pynut/ChangeLog
index 08acd156b8ff..64f9cd8765c5 100644
--- a/dev-python/pynut/ChangeLog
+++ b/dev-python/pynut/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pynut
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pynut/ChangeLog,v 1.1 2009/11/13 20:12:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pynut/ChangeLog,v 1.2 2009/11/14 22:52:00 arfrever Exp $
+
+ 14 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pynut-1.1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*pynut-1.1 (13 Nov 2009)
diff --git a/dev-python/pynut/pynut-1.1.ebuild b/dev-python/pynut/pynut-1.1.ebuild
index e77a790abe28..d84d8559f8e3 100644
--- a/dev-python/pynut/pynut-1.1.ebuild
+++ b/dev-python/pynut/pynut-1.1.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pynut/pynut-1.1.ebuild,v 1.1 2009/11/13 20:12:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pynut/pynut-1.1.ebuild,v 1.2 2009/11/14 22:52:00 arfrever Exp $
-inherit multilib python
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python
DESCRIPTION="An abstraction class written in Python to access NUT (Network UPS Tools) server"
HOMEPAGE="http://www.lestat.st/informatique/projets/pynut-en/"
@@ -13,20 +16,26 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-S=${WORKDIR}/python-${P}
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/python-${P}"
src_install() {
- python_version
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages
- doins PyNUT.py
+ installation() {
+ insinto $(python_get_sitedir)
+ doins PyNUT.py
+ }
+ python_execute_function -q installation
+
dodoc README
}
pkg_postinst() {
- python_version
- python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/PyNUT.py
+ python_mod_optimize PyNUT.py
}
pkg_postrm() {
- python_mod_cleanup
+ python_mod_cleanup PyNUT.py
}