summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-01 08:15:28 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-01 08:15:28 +0000
commitba0c30b7c21b35d32e9c3836e45f6049b3bae2f0 (patch)
treee749c674690948921a51139459ddcb12b7f2566b /dev-python/pynotifier
parentRe-remove redundant pyxml, origin Bug #45673 (diff)
downloadgentoo-2-ba0c30b7c21b35d32e9c3836e45f6049b3bae2f0.tar.gz
gentoo-2-ba0c30b7c21b35d32e9c3836e45f6049b3bae2f0.tar.bz2
gentoo-2-ba0c30b7c21b35d32e9c3836e45f6049b3bae2f0.zip
revbump; migrate -> distutils-r1
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pynotifier')
-rw-r--r--dev-python/pynotifier/ChangeLog10
-rw-r--r--dev-python/pynotifier/pynotifier-0.7.0-r2.ebuild29
2 files changed, 36 insertions, 3 deletions
diff --git a/dev-python/pynotifier/ChangeLog b/dev-python/pynotifier/ChangeLog
index 04c1e0e78af5..db58975e72d2 100644
--- a/dev-python/pynotifier/ChangeLog
+++ b/dev-python/pynotifier/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pynotifier
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pynotifier/ChangeLog,v 1.19 2011/10/24 05:37:32 tetromino Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pynotifier/ChangeLog,v 1.20 2013/07/01 08:15:28 idella4 Exp $
+
+*pynotifier-0.7.0-r2 (01 Jul 2013)
+
+ 01 Jul 2013; Ian Delaney <idella4@gentoo.org> +pynotifier-0.7.0-r2.ebuild:
+ revbump; migrate -> distutils-r1
24 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
pynotifier-0.7.0-r1.ebuild:
@@ -78,4 +83,3 @@
+pynotifier-0.5.8.ebuild:
Initial version, thanks to Dirk Meyer and Frittella Laurento
(bug #156497)
-
diff --git a/dev-python/pynotifier/pynotifier-0.7.0-r2.ebuild b/dev-python/pynotifier/pynotifier-0.7.0-r2.ebuild
new file mode 100644
index 000000000000..a097f6e45bfb
--- /dev/null
+++ b/dev-python/pynotifier/pynotifier-0.7.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pynotifier/pynotifier-0.7.0-r2.ebuild,v 1.1 2013/07/01 08:15:28 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="pyNotifier provides an implementation of a notifier/event scheduler."
+HOMEPAGE="http://www.bitkipper.net/"
+SRC_URI="http://www.bitkipper.net/bytes/debian/dists/unstable/source/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="qt4 gtk"
+
+DEPEND=""
+RDEPEND="dev-python/twisted
+ gtk? ( dev-python/pygobject:2[${PYTHON_USEDEP}] )
+ qt4? ( python_targets_python2_6? ( dev-python/PyQt4[X] )
+ python_targets_python2_7? ( dev-python/PyQt4[X] ) )"
+
+python_prepare_all() {
+ use gtk || rm notifier/nf_gtk.py
+ use qt4 || rm notifier/nf_qt.py
+ distutils-r1_python_prepare_all
+}