summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-26 18:42:26 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-26 18:42:26 +0000
commit5c5400c9a6bc93f06c152a6af0fd2b01604edadc (patch)
treee29ed7a1843d29c489610b597a6146115226eda3 /dev-python/pymongo
parentRemove kernels with possible early boot freeze (diff)
downloadgentoo-2-5c5400c9a6bc93f06c152a6af0fd2b01604edadc.tar.gz
gentoo-2-5c5400c9a6bc93f06c152a6af0fd2b01604edadc.tar.bz2
gentoo-2-5c5400c9a6bc93f06c152a6af0fd2b01604edadc.zip
return --bind_ip to starting mongod, disable 1 test conditionally confirmed from upstream, rm pkg_postinst recommend from jbergstroem wrt Bug #463310
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pymongo')
-rw-r--r--dev-python/pymongo/ChangeLog7
-rw-r--r--dev-python/pymongo/pymongo-2.5.1.ebuild17
2 files changed, 14 insertions, 10 deletions
diff --git a/dev-python/pymongo/ChangeLog b/dev-python/pymongo/ChangeLog
index 2f09ef25f9fa..7c07f58fe98e 100644
--- a/dev-python/pymongo/ChangeLog
+++ b/dev-python/pymongo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pymongo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/ChangeLog,v 1.23 2013/05/26 08:19:47 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/ChangeLog,v 1.24 2013/05/26 18:42:26 idella4 Exp $
+
+ 26 May 2013; Ian Delaney <idella4@gentoo.org> pymongo-2.5.1.ebuild,
+ pymongo-2.5.ebuild:
+ return --bind_ip to starting mongod, disable 1 test conditionally confirmed
+ from upstream, rm pkg_postinst recommend from jbergstroem wrt Bug #463310
26 May 2013; Ian Delaney <idella4@gentoo.org> pymongo-2.5.1.ebuild,
pymongo-2.5.ebuild:
diff --git a/dev-python/pymongo/pymongo-2.5.1.ebuild b/dev-python/pymongo/pymongo-2.5.1.ebuild
index 56b40d9b7463..d1145e9bd51c 100644
--- a/dev-python/pymongo/pymongo-2.5.1.ebuild
+++ b/dev-python/pymongo/pymongo-2.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.5.1.ebuild,v 1.3 2013/05/26 08:19:47 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.5.1.ebuild,v 1.4 2013/05/26 18:42:26 idella4 Exp $
EAPI=5
@@ -77,7 +77,7 @@ python_test() {
LC_ALL=C \
mongod --dbpath "${dbpath}" --smallfiles --nojournal \
- --port ${DB_PORT} \
+ --bind_ip ${DB_IP} --port ${DB_PORT} \
--unixSocketPrefix "${TMPDIR}" \
--logpath "${logpath}" --fork \
&& sleep 2
@@ -101,12 +101,16 @@ python_test() {
done
local failed
- #https://jira.mongodb.org/browse/PYTHON-521
+ #https://jira.mongodb.org/browse/PYTHON-521, py2.[6-7] has intermittent failure with gevent
pushd "${BUILD_DIR}"/../ > /dev/null
if [[ "${EPYTHON}" == python3* ]]; then
2to3 --no-diffs -w test
- fi
esetup.py test || failed=1
+ elif [[ "${EPYTHON}" == 'python2.7' || "${EPYTHON}" == 'python2.6' ]]; then
+ sed -e 's:test_socket_reclamation:_&:' \
+ -i test/test_pooling_base.py || die
+ fi
+ esetup.py test || failed=1
mongod --dbpath "${dbpath}" --shutdown
@@ -128,8 +132,3 @@ python_install_all() {
distutils-r1_python_install_all
}
-
-pkg_postinst() {
- ewarn "Important changes on this release, make sure to read the changelog:"
- ewarn "http://api.mongodb.org/python/${PV}/changelog.html"
-}