summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-06 20:03:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-06 20:03:58 +0000
commitdf6781ec3589e57f17de754c74f88b93f93c5ec0 (patch)
treedee1949c759a7d3d1aa332d5723a7fc4597adc1d /dev-python/pylint
parentMask dev-lang/wml for removal. (diff)
downloadgentoo-2-df6781ec3589e57f17de754c74f88b93f93c5ec0.tar.gz
gentoo-2-df6781ec3589e57f17de754c74f88b93f93c5ec0.tar.bz2
gentoo-2-df6781ec3589e57f17de754c74f88b93f93c5ec0.zip
Version bump.
(Portage version: 2.2.0_alpha7_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog8
-rw-r--r--dev-python/pylint/pylint-0.22.0.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index d39cef857bd8..48a0b76fd78b 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.77 2010/10/25 12:08:29 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.78 2010/12/06 20:03:58 arfrever Exp $
+
+*pylint-0.22.0 (06 Dec 2010)
+
+ 06 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pylint-0.22.0.ebuild:
+ Version bump.
25 Oct 2010; Christian Faulhammer <fauli@gentoo.org> pylint-0.21.3.ebuild:
stable x86, bug 341607
diff --git a/dev-python/pylint/pylint-0.22.0.ebuild b/dev-python/pylint/pylint-0.22.0.ebuild
new file mode 100644
index 000000000000..89143ea8b877
--- /dev/null
+++ b/dev-python/pylint/pylint-0.22.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.22.0.ebuild,v 1.1 2010/12/06 20:03:58 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.5"
+PYTHON_USE_WITH="tk"
+PYTHON_USE_WITH_OPT="tk"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4"
+
+inherit distutils
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="http://www.logilab.org/projects/pylint/ http://pypi.python.org/pypi/pylint"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="examples tk"
+
+# Versions specified in __pkginfo__.py.
+RDEPEND=">=dev-python/logilab-common-0.53.0
+ >=dev-python/astng-0.21.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+DOCS="doc/*.txt"
+
+src_prepare() {
+ distutils_src_prepare
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+ find ! -path "*/test/*" -name "*.py" ! -name "setup.py" -print | xargs 2to3-${PYTHON_ABI} -nw --no-diffs
+ find -path "*/test/*" -name "*.py" ! -name "setup.py" -print | xargs 2to3-${PYTHON_ABI} -nw --no-diffs
+
+ # Ignore errors during transformation of data of tests.
+ :
+ }
+ python_execute_function -s conversion
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build/lib" pytest -v
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if ! use tk; then
+ rm -f "${ED}usr/bin/pylint-gui"*
+ fi
+
+ doman man/{pylint,pyreverse}.1 || die "doman failed"
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc failed"
+ fi
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/pylint/test"
+ }
+ python_execute_function -q delete_tests
+}