summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-10-18 19:11:54 +0000
committerTim Harder <radhermit@gentoo.org>2011-10-18 19:11:54 +0000
commitd38da10692138d29964f71be41c699c9a3d3172f (patch)
tree78e67e3ccb60a7e1ee85859de21bfd52af9d9207 /dev-python/pylint
parentVersion bump (bug #387249 by Beetle B.). (diff)
downloadgentoo-2-d38da10692138d29964f71be41c699c9a3d3172f.tar.gz
gentoo-2-d38da10692138d29964f71be41c699c9a3d3172f.tar.bz2
gentoo-2-d38da10692138d29964f71be41c699c9a3d3172f.zip
Remove old.
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog6
-rw-r--r--dev-python/pylint/pylint-0.21.3.ebuild56
-rw-r--r--dev-python/pylint/pylint-0.22.0.ebuild72
3 files changed, 5 insertions, 129 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index 39e551cf8854..4269315e72d0 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.84 2011/10/18 19:09:49 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.85 2011/10/18 19:11:54 radhermit Exp $
+
+ 18 Oct 2011; Tim Harder <radhermit@gentoo.org> -pylint-0.21.3.ebuild,
+ -pylint-0.22.0.ebuild:
+ Remove old.
*pylint-0.25.0 (18 Oct 2011)
diff --git a/dev-python/pylint/pylint-0.21.3.ebuild b/dev-python/pylint/pylint-0.21.3.ebuild
deleted file mode 100644
index 7976338c1f55..000000000000
--- a/dev-python/pylint/pylint-0.21.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.21.3.ebuild,v 1.5 2011/01/06 21:47:55 ranger Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="tk"
-PYTHON_USE_WITH_OPT="tk"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="http://www.logilab.org/projects/pylint/ http://pypi.python.org/pypi/pylint"
-SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="examples tk"
-
-# Versions specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.50.1
- >=dev-python/astng-0.20.1"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-DOCS="doc/*.txt"
-
-src_test() {
- if has_version "<dev-python/logilab-common-0.52.0"; then
- ewarn "Skipping tests due to old version of dev-python/logilab-common"
- return
- fi
-
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" pytest -v
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if ! use tk; then
- rm -f "${ED}usr/bin/pylint-gui"*
- fi
-
- doman man/{pylint,pyreverse}.1 || die "doman failed"
-
- if use examples; then
- docinto examples
- dodoc examples/* || die "dodoc failed"
- fi
-}
diff --git a/dev-python/pylint/pylint-0.22.0.ebuild b/dev-python/pylint/pylint-0.22.0.ebuild
deleted file mode 100644
index 89143ea8b877..000000000000
--- a/dev-python/pylint/pylint-0.22.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.22.0.ebuild,v 1.1 2010/12/06 20:03:58 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.5"
-PYTHON_USE_WITH="tk"
-PYTHON_USE_WITH_OPT="tk"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4"
-
-inherit distutils
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="http://www.logilab.org/projects/pylint/ http://pypi.python.org/pypi/pylint"
-SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="examples tk"
-
-# Versions specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.53.0
- >=dev-python/astng-0.21.0"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-
-DOCS="doc/*.txt"
-
-src_prepare() {
- distutils_src_prepare
-
- conversion() {
- [[ "${PYTHON_ABI}" == 2.* ]] && return
- find ! -path "*/test/*" -name "*.py" ! -name "setup.py" -print | xargs 2to3-${PYTHON_ABI} -nw --no-diffs
- find -path "*/test/*" -name "*.py" ! -name "setup.py" -print | xargs 2to3-${PYTHON_ABI} -nw --no-diffs
-
- # Ignore errors during transformation of data of tests.
- :
- }
- python_execute_function -s conversion
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build/lib" pytest -v
- }
- python_execute_function -s testing
-}
-
-src_install() {
- distutils_src_install
-
- if ! use tk; then
- rm -f "${ED}usr/bin/pylint-gui"*
- fi
-
- doman man/{pylint,pyreverse}.1 || die "doman failed"
-
- if use examples; then
- docinto examples
- dodoc examples/* || die "dodoc failed"
- fi
-
- delete_tests() {
- rm -fr "${ED}$(python_get_sitedir)/pylint/test"
- }
- python_execute_function -q delete_tests
-}