summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-30 07:49:52 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-30 07:49:52 +0000
commit89091d1ebc0ddade2611200f206e56fa4e636d74 (patch)
tree773b05875e3d325b64715521006e1a2abbf1fe33 /dev-python/pylint
parentVersion bump. (diff)
downloadgentoo-2-89091d1ebc0ddade2611200f206e56fa4e636d74.tar.gz
gentoo-2-89091d1ebc0ddade2611200f206e56fa4e636d74.tar.bz2
gentoo-2-89091d1ebc0ddade2611200f206e56fa4e636d74.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog7
-rw-r--r--dev-python/pylint/pylint-0.26.0.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index ad2fc37800f1..cba180077df6 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.88 2012/08/27 15:24:56 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.89 2012/10/30 07:49:52 patrick Exp $
+
+*pylint-0.26.0 (30 Oct 2012)
+
+ 30 Oct 2012; Patrick Lauer <patrick@gentoo.org> +pylint-0.26.0.ebuild:
+ Bump
27 Aug 2012; Mike Gilbert <floppym@gentoo.org> pylint-0.23.0.ebuild,
pylint-0.25.0.ebuild, pylint-0.25.1.ebuild, pylint-0.25.2.ebuild:
diff --git a/dev-python/pylint/pylint-0.26.0.ebuild b/dev-python/pylint/pylint-0.26.0.ebuild
new file mode 100644
index 000000000000..a2700bdf7946
--- /dev/null
+++ b/dev-python/pylint/pylint-0.26.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.26.0.ebuild,v 1.1 2012/10/30 07:49:52 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4"
+
+inherit distutils
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="http://www.logilab.org/project/pylint http://pypi.python.org/pypi/pylint"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="examples"
+
+# Versions specified in __pkginfo__.py.
+RDEPEND=">=dev-python/logilab-common-0.53.0
+ >=dev-python/astng-0.21.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS="doc/*.txt"
+
+src_test() {
+ testing() {
+ # Test suite broken with Python 3.
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
+
+ PYTHONPATH="build/lib" pytest -v
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ distutils_src_install
+
+ doman man/{pylint,pyreverse}.1 || die "doman failed"
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc failed"
+ fi
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/pylint/test"
+ }
+ python_execute_function -q delete_tests
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ elog "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled."
+}