summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-13 07:05:56 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-13 07:05:56 +0000
commit3a4f2c0f992cdf1e7e9132adabd06a624c95ad1b (patch)
treee896a455ba0dd4be5831df99613354f097ae25cd /dev-python/pylint
parentVersion bump. (diff)
downloadgentoo-2-3a4f2c0f992cdf1e7e9132adabd06a624c95ad1b.tar.gz
gentoo-2-3a4f2c0f992cdf1e7e9132adabd06a624c95ad1b.tar.bz2
gentoo-2-3a4f2c0f992cdf1e7e9132adabd06a624c95ad1b.zip
revbump
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog7
-rw-r--r--dev-python/pylint/pylint-0.27.0-r1.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index cf7747c3ffc7..d3d4b2a9b169 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.94 2013/03/11 06:14:51 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.95 2013/03/13 07:05:56 idella4 Exp $
+
+*pylint-0.27.0-r1 (13 Mar 2013)
+
+ 13 Mar 2013; Ian Delaney <idella4@gentoo.org> +pylint-0.27.0-r1.ebuild:
+ revbump
*pylint-0.27.0 (11 Mar 2013)
diff --git a/dev-python/pylint/pylint-0.27.0-r1.ebuild b/dev-python/pylint/pylint-0.27.0-r1.ebuild
new file mode 100644
index 000000000000..09ae0995f680
--- /dev/null
+++ b/dev-python/pylint/pylint-0.27.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.27.0-r1.ebuild,v 1.1 2013/03/13 07:05:56 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{5,6,7} python{3_1,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="http://www.logilab.org/project/pylint http://pypi.python.org/pypi/pylint"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="examples"
+
+# Versions specified in __pkginfo__.py.
+RDEPEND=">=dev-python/logilab-common-0.53.0
+ >=dev-python/astng-0.21.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS=( doc/FAQ.txt doc/features.txt doc/manual.txt doc/quickstart.txt )
+
+python_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.26.0-gtktest.patch
+}
+
+python_test() {
+ # Test suite broken with Python 3, 2.5
+ [[ "${EPYTHON:6:1}" == 3 || "${EPYTHON:6:3}" == '2.5' ]] && return
+ pytest || die
+}
+
+src_install_all() {
+ doman man/{pylint,pyreverse}.1 || die "doman failed"
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc failed"
+ fi
+
+# delete_tests() {
+# rm -fr "${ED}$(python_get_sitedir)/pylint/test"
+# }
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ elog "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled."
+}