summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-04 15:25:34 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-04 15:25:34 +0000
commitdf816dc4f34257cce441d98d108cd52d75c70460 (patch)
tree65b0e044efe6359202cfb10e05e5518acd160be8 /dev-python/pygtkglext
parentAdded ~sparc keyword. (diff)
downloadgentoo-2-df816dc4f34257cce441d98d108cd52d75c70460.tar.gz
gentoo-2-df816dc4f34257cce441d98d108cd52d75c70460.tar.bz2
gentoo-2-df816dc4f34257cce441d98d108cd52d75c70460.zip
python 2.3 support blah blah sandbox issue
Diffstat (limited to 'dev-python/pygtkglext')
-rw-r--r--dev-python/pygtkglext/ChangeLog6
-rw-r--r--dev-python/pygtkglext/pygtkglext-1.0.0.ebuild18
-rw-r--r--dev-python/pygtkglext/pygtkglext-1.0.1.ebuild23
3 files changed, 31 insertions, 16 deletions
diff --git a/dev-python/pygtkglext/ChangeLog b/dev-python/pygtkglext/ChangeLog
index 255bd76d978e..a6396aad1bf8 100644
--- a/dev-python/pygtkglext/ChangeLog
+++ b/dev-python/pygtkglext/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygtkglext
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkglext/ChangeLog,v 1.5 2003/12/06 13:43:16 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkglext/ChangeLog,v 1.6 2004/01/04 15:25:34 liquidx Exp $
+
+ 04 Jan 2004; Alastair Tse <liquidx@gentoo.org> pygtkglext-1.0.0.ebuild,
+ pygtkglext-1.0.1.ebuild:
+ add python2.3 support
*pygtkglext-1.0.1 (06 Dec 2003)
diff --git a/dev-python/pygtkglext/pygtkglext-1.0.0.ebuild b/dev-python/pygtkglext/pygtkglext-1.0.0.ebuild
index 351f1597e88a..af4d201743ea 100644
--- a/dev-python/pygtkglext/pygtkglext-1.0.0.ebuild
+++ b/dev-python/pygtkglext/pygtkglext-1.0.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkglext/pygtkglext-1.0.0.ebuild,v 1.2 2003/12/06 13:43:16 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkglext/pygtkglext-1.0.0.ebuild,v 1.3 2004/01/04 15:25:34 liquidx Exp $
+
+inherit python
DESCRIPTION="Python bindings to GtkGLExt"
HOMEPAGE="http://gtkglext.sourceforge.net/"
@@ -10,7 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND=">=dev-lang/python-2.2
+DEPEND=">=dev-lang/python-2.2.3-r3
>=dev-python/pygtk-2
>=dev-libs/glib-2.0
>=x11-libs/gtk+-2.0
@@ -21,9 +23,6 @@ DEPEND=">=dev-lang/python-2.2
virtual/glu"
src_compile() {
- # ugly hack for sandbox (opens file readwrite, but only really reads)
- addwrite /usr/share/pygtk/2.0/codegen
-
econf
emake || die
}
@@ -34,3 +33,12 @@ src_install() {
insinto /usr/share/doc/${PF}/examples
doins examples/*.py
}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
diff --git a/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild b/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild
index 3af32d1fce9c..5e4a882f1d3a 100644
--- a/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild
+++ b/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild,v 1.1 2003/12/06 13:43:16 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild,v 1.2 2004/01/04 15:25:34 liquidx Exp $
+
+inherit python
DESCRIPTION="Python bindings to GtkGLExt"
HOMEPAGE="http://gtkglext.sourceforge.net/"
SRC_URI="mirror://sourceforge/gtkglext/${P}.tar.bz2"
-LICENSE="LGPL-2.1 GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-
-DEPEND=">=dev-lang/python-2.2
+DEPEND=">=dev-lang/python-2.2.3-r3
>=dev-python/pygtk-2
>=dev-libs/glib-2.0
>=x11-libs/gtk+-2.0
@@ -22,20 +23,22 @@ DEPEND=">=dev-lang/python-2.2
virtual/glu"
src_compile() {
-
- # ugly hack for sandbox (opens file readwrite, but only really reads)
- addwrite /usr/share/pygtk/2.0/codegen
-
econf
emake || die
-
}
src_install() {
-
make DESTDIR=${D} install || die
dodoc README COPYING* AUTHORS ChangeLog
insinto /usr/share/doc/${PF}/examples
doins examples/*.py
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/gtk-2.0
+}
+pkg_postrm() {
+ python_mod_cleanup
}