summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-05-28 14:03:45 +0000
committerRémi Cardona <remi@gentoo.org>2008-05-28 14:03:45 +0000
commit90939878ab48c2f6fcca5e05657bc5afa87a805a (patch)
tree6a2ceb74e5b29472ee58538a06e295cc319bbedc /dev-python/pygtk
parentefte: fix dependencies (diff)
downloadgentoo-2-90939878ab48c2f6fcca5e05657bc5afa87a805a.tar.gz
gentoo-2-90939878ab48c2f6fcca5e05657bc5afa87a805a.tar.bz2
gentoo-2-90939878ab48c2f6fcca5e05657bc5afa87a805a.zip
dev-python/pygtk: fix bug #194343 and bug #209531, add amd64 keyword back
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-python/pygtk')
-rw-r--r--dev-python/pygtk/ChangeLog9
-rw-r--r--dev-python/pygtk/files/pygtk-2.12.1-fix-amd64.patch13
-rw-r--r--dev-python/pygtk/files/pygtk-2.12.1-fix-codegen-location.patch39
-rw-r--r--dev-python/pygtk/pygtk-2.12.1-r1.ebuild79
4 files changed, 139 insertions, 1 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index f536bbb0df26..b5263a086b47 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pygtk
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.180 2008/04/25 17:11:06 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.181 2008/05/28 14:03:44 remi Exp $
+
+*pygtk-2.12.1-r1 (28 May 2008)
+
+ 28 May 2008; Rémi Cardona <remi@gentoo.org>
+ +files/pygtk-2.12.1-fix-amd64.patch,
+ +files/pygtk-2.12.1-fix-codegen-location.patch, +pygtk-2.12.1-r1.ebuild:
+ fix bug #194343 and bug #209531, add amd64 keyword back
25 Apr 2008; Samuli Suominen <drac@gentoo.org>
+files/pygtk-2.12.0-extrafuncs.patch, +pygtk-2.12.0-r1.ebuild:
diff --git a/dev-python/pygtk/files/pygtk-2.12.1-fix-amd64.patch b/dev-python/pygtk/files/pygtk-2.12.1-fix-amd64.patch
new file mode 100644
index 000000000000..0fbcf851a668
--- /dev/null
+++ b/dev-python/pygtk/files/pygtk-2.12.1-fix-amd64.patch
@@ -0,0 +1,13 @@
+Index: gtk/gtk.override
+===================================================================
+--- gtk/gtk.override (revision 2949)
++++ gtk/gtk.override (working copy)
+@@ -1168,7 +1168,7 @@
+ static GSource *
+ pygtk_main_watch_new(void)
+ {
+- return g_source_new(&pygtk_main_watch_funcs, sizeof(GSource));
++ return g_source_new(&pygtk_main_watch_funcs, sizeof(PySignalWatchSource));
+ }
+
+
diff --git a/dev-python/pygtk/files/pygtk-2.12.1-fix-codegen-location.patch b/dev-python/pygtk/files/pygtk-2.12.1-fix-codegen-location.patch
new file mode 100644
index 000000000000..4d65927f5e01
--- /dev/null
+++ b/dev-python/pygtk/files/pygtk-2.12.1-fix-codegen-location.patch
@@ -0,0 +1,39 @@
+Index: pygtk-2.0.pc.in
+===================================================================
+--- pygtk-2.0.pc.in (revision 2949)
++++ pygtk-2.0.pc.in (working copy)
+@@ -12,7 +12,7 @@
+
+ # same here. Useful when calling the code generator in addon packages.
+ defsdir=${datadir}/pygtk/2.0/defs
+-codegendir=${datadir}/pygtk/2.0/codegen
++codegendir=${pyexecdir}/gtk-2.0/codegen
+
+ Name: PyGTK
+ Description: Python bindings for GTK+ and related libraries
+Index: codegen/pygtk-codegen-2.0.in
+===================================================================
+--- codegen/pygtk-codegen-2.0.in (revision 2949)
++++ codegen/pygtk-codegen-2.0.in (working copy)
+@@ -3,7 +3,7 @@
+ prefix=@prefix@
+ datarootdir=@datarootdir@
+ datadir=@datadir@
+-codegendir=${datadir}/pygtk/2.0/codegen
++codegendir=@pyexecdir@/gtk-2.0/codegen
+
+ PYTHONPATH=$codegendir
+ export PYTHONPATH
+Index: codegen/Makefile.am
+===================================================================
+--- codegen/Makefile.am (revision 2949)
++++ codegen/Makefile.am (working copy)
+@@ -2,7 +2,7 @@
+
+ bin_SCRIPTS = pygtk-codegen-$(PLATFORM_VERSION)
+
+-codegendir = $(pkgdatadir)/$(PLATFORM_VERSION)/codegen
++codegendir = $(pyexecdir)/gtk-2.0/codegen
+
+ codegen_PYTHON = \
+ __init__.py \
diff --git a/dev-python/pygtk/pygtk-2.12.1-r1.ebuild b/dev-python/pygtk/pygtk-2.12.1-r1.ebuild
new file mode 100644
index 000000000000..749cf0225483
--- /dev/null
+++ b/dev-python/pygtk/pygtk-2.12.1-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.12.1-r1.ebuild,v 1.1 2008/05/28 14:03:44 remi Exp $
+
+inherit gnome.org python flag-o-matic eutils virtualx
+
+DESCRIPTION="GTK+2 bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=x11-libs/pango-1.16.0
+ >=dev-libs/atk-1.12.0
+ >=x11-libs/gtk+-2.11.6
+ >=gnome-base/libglade-2.5.0
+ >=dev-lang/python-2.4.4-r5
+ >=dev-python/pycairo-1.0.2
+ >=dev-python/pygobject-2.14
+ !arm? ( dev-python/numeric )"
+
+DEPEND="${RDEPEND}
+ doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
+ >=dev-util/pkgconfig-0.9"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix for bug #209531
+ epatch "${FILESDIR}/${PN}-2.12.1-fix-amd64.patch"
+
+ # fix for bug #194343
+ epatch "${FILESDIR}/${PN}-2.12.1-fix-codegen-location.patch"
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+}
+
+src_compile() {
+ use hppa && append-flags -ffunction-sections
+ econf $(use_enable doc docs) --enable-thread || die
+ # possible problems with parallel builds (#45776)
+ #emake -j1 || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
+
+ if use examples; then
+ rm examples/Makefile*
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ cd tests
+ Xemake check-local || die "tests failed"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+ rm -f "${ROOT}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.{py,pth}
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+}