summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-10-02 19:09:24 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-10-02 19:09:24 +0000
commit8d44337245d3b9a00e0d3ccf70da1cf90b9e2450 (patch)
tree435a8eb9b934ef4b8f9ccb70a53f093b5b477a5f /dev-python/pygtk
parentAdd unit file (#486594 by nE0sIghT), drop old. (diff)
downloadgentoo-2-8d44337245d3b9a00e0d3ccf70da1cf90b9e2450.tar.gz
gentoo-2-8d44337245d3b9a00e0d3ccf70da1cf90b9e2450.tar.bz2
gentoo-2-8d44337245d3b9a00e0d3ccf70da1cf90b9e2450.zip
Fix test failure (bug #486602, thanks to eroen).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'dev-python/pygtk')
-rw-r--r--dev-python/pygtk/ChangeLog6
-rw-r--r--dev-python/pygtk/files/pygtk-2.24.0-test_dialog.patch28
-rw-r--r--dev-python/pygtk/pygtk-2.24.0-r4.ebuild5
3 files changed, 37 insertions, 2 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index f50b49e93898..c7899c34b75a 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.291 2013/09/29 10:21:40 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.292 2013/10/02 19:09:24 tetromino Exp $
+
+ 02 Oct 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ pygtk-2.24.0-r4.ebuild, +files/pygtk-2.24.0-test_dialog.patch:
+ Fix test failure (bug #486602, thanks to eroen).
*pygtk-2.24.0-r4 (29 Sep 2013)
diff --git a/dev-python/pygtk/files/pygtk-2.24.0-test_dialog.patch b/dev-python/pygtk/files/pygtk-2.24.0-test_dialog.patch
new file mode 100644
index 000000000000..832007af2328
--- /dev/null
+++ b/dev-python/pygtk/files/pygtk-2.24.0-test_dialog.patch
@@ -0,0 +1,28 @@
+From eb92ecdfe7e310499743a5686560e18bb48ef0f0 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Wed, 2 Oct 2013 14:51:20 -0400
+Subject: [PATCH] tests: fix MessageDialogTest.testSubclass
+
+Don't check sub.__gtype__ until we set sub
+
+https://bugzilla.gnome.org/show_bug.cgi?id=709304
+---
+ tests/test_dialog.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_dialog.py b/tests/test_dialog.py
+index a6a3ce5..6540be3 100644
+--- a/tests/test_dialog.py
++++ b/tests/test_dialog.py
+@@ -20,7 +20,7 @@ class MessageDialogTest(unittest.TestCase):
+ print sub.__gtype__.name
+ self.assertEqual(sub.__gtype__.name, 'GtkMessageDialog')
+
+- type('Sub', (gtk.MessageDialog,), {'__gtype_name__': 'SubDialog'})
++ sub = type('Sub', (gtk.MessageDialog,), {'__gtype_name__': 'SubDialog'})
+ self.assertEqual(sub.__gtype__.name, 'SubDialog')
+
+ def testDialogLeak(self):
+--
+1.8.3.2
+
diff --git a/dev-python/pygtk/pygtk-2.24.0-r4.ebuild b/dev-python/pygtk/pygtk-2.24.0-r4.ebuild
index e20315193047..3e21a3c3352f 100644
--- a/dev-python/pygtk/pygtk-2.24.0-r4.ebuild
+++ b/dev-python/pygtk/pygtk-2.24.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.24.0-r4.ebuild,v 1.1 2013/09/29 10:21:40 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.24.0-r4.ebuild,v 1.2 2013/10/02 19:09:24 tetromino Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -45,6 +45,9 @@ src_prepare() {
# Fail when tests are failing, bug #391307
epatch "${FILESDIR}/${PN}-2.24.0-test-fail.patch"
+ # Fix broken tests, https://bugzilla.gnome.org/show_bug.cgi?id=709304
+ epatch "${FILESDIR}/${P}-test_dialog.patch"
+
# Examples is handled "manually"
sed -e 's/\(SUBDIRS = .* \)examples/\1/' \
-i Makefile.am Makefile.in || die