summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-03-08 01:05:47 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-03-08 01:05:47 +0000
commit5b1ea7bea29257aefeaeb30d8e06a2dedaf64cc9 (patch)
treee85c0363c29f77c99d7eb90163b9f39e85635ebc /dev-python/pygtk
parentBump to 2.14.17. Build fixes and enhancements to linc. Clean up old revisions. (diff)
downloadgentoo-2-5b1ea7bea29257aefeaeb30d8e06a2dedaf64cc9.tar.gz
gentoo-2-5b1ea7bea29257aefeaeb30d8e06a2dedaf64cc9.tar.bz2
gentoo-2-5b1ea7bea29257aefeaeb30d8e06a2dedaf64cc9.zip
Bump to 2.14.1. Documentation enhancements.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pygtk')
-rw-r--r--dev-python/pygtk/ChangeLog7
-rw-r--r--dev-python/pygtk/pygtk-2.14.1.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index f245fc09006d..5cf4b37a0708 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pygtk
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.199 2009/03/06 15:33:21 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.200 2009/03/08 01:05:47 eva Exp $
+
+*pygtk-2.14.1 (08 Mar 2009)
+
+ 08 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org> +pygtk-2.14.1.ebuild:
+ Bump to 2.14.1. Documentation enhancements.
06 Mar 2009; Brent Baude <ranger@gentoo.org> pygtk-2.14.0.ebuild:
Marking pygtk-2.14.0 ppc stable for bug 260063
diff --git a/dev-python/pygtk/pygtk-2.14.1.ebuild b/dev-python/pygtk/pygtk-2.14.1.ebuild
new file mode 100644
index 000000000000..47978add9c5d
--- /dev/null
+++ b/dev-python/pygtk/pygtk-2.14.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.14.1.ebuild,v 1.1 2009/03/08 01:05:47 eva Exp $
+
+inherit eutils flag-o-matic gnome.org python virtualx
+
+DESCRIPTION="GTK+2 bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=x11-libs/pango-1.16.0
+ >=dev-libs/atk-1.12.0
+ >=x11-libs/gtk+-2.13.6
+ >=gnome-base/libglade-2.5.0
+ >=dev-lang/python-2.4.4-r5
+ >=dev-python/pycairo-1.0.2
+ >=dev-python/pygobject-2.15.3
+ !arm? ( dev-python/numeric )"
+
+DEPEND="${RDEPEND}
+ doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
+ >=dev-util/pkgconfig-0.9"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix declaration of codegen in .pc
+ epatch "${FILESDIR}/${PN}-2.13.0-fix-codegen-location.patch"
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+}
+
+src_compile() {
+ use hppa && append-flags -ffunction-sections
+ econf $(use_enable doc docs) --enable-thread
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
+
+ if use examples; then
+ rm examples/Makefile*
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ cd tests
+ Xemake check-local || die "tests failed"
+}
+
+pkg_postinst() {
+ python_version
+ python_need_rebuild
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/gtk-2.0
+ rm -f "${ROOT}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.{py,pth}
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+}