summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-03 14:26:01 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-03 14:26:01 +0000
commit513b40a27b8a3f8f9f5f84f21cd581a3ad1a2a59 (patch)
tree1ecef4fca24fb219658d3885428834cbe2c8cdab /dev-python/pygtk
parentfix licenses (diff)
downloadgentoo-2-513b40a27b8a3f8f9f5f84f21cd581a3ad1a2a59.tar.gz
gentoo-2-513b40a27b8a3f8f9f5f84f21cd581a3ad1a2a59.tar.bz2
gentoo-2-513b40a27b8a3f8f9f5f84f21cd581a3ad1a2a59.zip
old
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-python/pygtk')
-rw-r--r--dev-python/pygtk/ChangeLog5
-rw-r--r--dev-python/pygtk/pygtk-2.24.0-r2.ebuild104
2 files changed, 4 insertions, 105 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index de55bb3bf2dc..569e5d753fb4 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pygtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.289 2013/05/03 14:23:59 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.290 2013/05/03 14:26:01 ssuominen Exp $
+
+ 03 May 2013; Samuli Suominen <ssuominen@gentoo.org> -pygtk-2.24.0-r2.ebuild:
+ old
03 May 2013; Samuli Suominen <ssuominen@gentoo.org> pygtk-2.24.0-r3.ebuild:
Use AC_CONFIG_HEADERS instead of AM_CONFIG_HEADER for automake-1.13
diff --git a/dev-python/pygtk/pygtk-2.24.0-r2.ebuild b/dev-python/pygtk/pygtk-2.24.0-r2.ebuild
deleted file mode 100644
index 930cd0c72ea1..000000000000
--- a/dev-python/pygtk/pygtk-2.24.0-r2.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.24.0-r2.ebuild,v 1.15 2012/05/13 20:02:41 aballier Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME_TARBALL_SUFFIX="bz2"
-
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-# dev-python/pycairo does not support Python 2.4 / 2.5.
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython 2.7-pypy-*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-
-inherit alternatives autotools eutils flag-o-matic gnome.org python virtualx gnome2-utils
-
-DESCRIPTION="GTK+2 bindings for Python"
-HOMEPAGE="http://www.pygtk.org/"
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-libs/glib-2.8:2
- >=x11-libs/pango-1.16
- >=dev-libs/atk-1.12
- >=x11-libs/gtk+-2.24:2
- >=dev-python/pycairo-1.0.2
- >=dev-python/pygobject-2.21.3:2
- dev-python/numpy
- >=gnome-base/libglade-2.5:2.0
-"
-DEPEND="${RDEPEND}
- doc? (
- dev-libs/libxslt
- >=app-text/docbook-xsl-stylesheets-1.70.1 )
- virtual/pkgconfig"
-
-src_prepare() {
- # Let tests pass without permissions problems, bug #245103
- gnome2_environment_reset
-
- # Fix declaration of codegen in .pc
- epatch "${FILESDIR}/${PN}-2.13.0-fix-codegen-location.patch"
- epatch "${FILESDIR}/${PN}-2.14.1-libdir-pc.patch"
-
- # Disable pyc compiling
- echo '#!/bin/sh' > py-compile
-
- AT_M4DIR="m4" eautoreconf
-
- python_copy_sources
-}
-
-src_configure() {
- use hppa && append-flags -ffunction-sections
- python_src_configure \
- $(use_enable doc docs) \
- --with-glade \
- --enable-thread
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
-
- testing() {
- cd tests
- Xemake check-local
- }
- python_execute_function -s testing
-}
-
-src_install() {
- python_src_install
- python_clean_installation_image
- dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
-
- if use examples; then
- rm examples/Makefile*
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize gtk-2.0
-
- create_symlinks() {
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
- }
- python_execute_function create_symlinks
-}
-
-pkg_postrm() {
- python_mod_cleanup gtk-2.0
-
- create_symlinks() {
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
- }
- python_execute_function create_symlinks
-}