summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 01:03:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 01:03:35 +0000
commit25cdb331f9a13848ac8d6f42352137b56e8159e8 (patch)
treec0eceb82d191efac4de5a80323f15d41786d4d9b /dev-python/pygraphviz
parentInclude COPYING-CMAKE-SCRIPTS (diff)
downloadgentoo-2-25cdb331f9a13848ac8d6f42352137b56e8159e8.tar.gz
gentoo-2-25cdb331f9a13848ac8d6f42352137b56e8159e8.tar.bz2
gentoo-2-25cdb331f9a13848ac8d6f42352137b56e8159e8.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pygraphviz')
-rw-r--r--dev-python/pygraphviz/ChangeLog6
-rw-r--r--dev-python/pygraphviz/pygraphviz-0.99.1.ebuild24
2 files changed, 20 insertions, 10 deletions
diff --git a/dev-python/pygraphviz/ChangeLog b/dev-python/pygraphviz/ChangeLog
index 2fcd3bfb75a1..19a93a572aa5 100644
--- a/dev-python/pygraphviz/ChangeLog
+++ b/dev-python/pygraphviz/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygraphviz
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygraphviz/ChangeLog,v 1.3 2010/06/01 15:15:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygraphviz/ChangeLog,v 1.4 2010/06/30 01:03:35 arfrever Exp $
+
+ 30 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pygraphviz-0.99.1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
01 Jun 2010; Joseph Jezak <josejx@gentoo.org> pygraphviz-0.99.1.ebuild:
Marked ~ppc for bug #317225.
diff --git a/dev-python/pygraphviz/pygraphviz-0.99.1.ebuild b/dev-python/pygraphviz/pygraphviz-0.99.1.ebuild
index 8898bdaa86d7..6ce4cc02ee4d 100644
--- a/dev-python/pygraphviz/pygraphviz-0.99.1.ebuild
+++ b/dev-python/pygraphviz/pygraphviz-0.99.1.ebuild
@@ -1,13 +1,16 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygraphviz/pygraphviz-0.99.1.ebuild,v 1.3 2010/06/01 15:15:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygraphviz/pygraphviz-0.99.1.ebuild,v 1.4 2010/06/30 01:03:35 arfrever Exp $
-EAPI=2
-NEED_PYTHON="2.4"
-inherit eutils distutils
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
DESCRIPTION="Python bindings for the agraph library in the graphviz package."
-HOMEPAGE="http://networkx.lanl.gov/pygraphviz/"
+HOMEPAGE="http://networkx.lanl.gov/pygraphviz/ http://pypi.python.org/pypi/pygraphviz"
SRC_URI="http://networkx.lanl.gov/download/${PN}/${P}.tar.gz"
LICENSE="BSD"
@@ -19,17 +22,20 @@ RDEPEND=">=media-gfx/graphviz-2.12"
DEPEND="${RDEPEND}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-setup.py.patch
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-setup.py.patch"
}
src_test() {
- cd build/lib*
- PYTHONPATH=. ${python} -c "import pygraphviz; pygraphviz.test()" \
- || die "tests failed"
+ testing() {
+ "$(PYTHON)" -c "import sys; sys.path.insert(0, '$(ls -d build-${PYTHON_ABI}/lib.*)'); import pygraphviz; pygraphviz.test()"
+ }
+ python_execute_function testing
}
src_install() {
distutils_src_install
+
if use examples; then
insinto /usr/share/doc/${PF}
doins -r examples || die