summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2007-09-26 13:15:05 +0000
committerMart Raudsepp <leio@gentoo.org>2007-09-26 13:15:05 +0000
commit7df4e493715ec4a011c5767bb2fdb0e9f7b5f8ec (patch)
treec50472c3f3ecf9adaea4b9774f166c6d7af5f5c4 /dev-python/pygobject
parentRemove old versions. (diff)
downloadgentoo-2-7df4e493715ec4a011c5767bb2fdb0e9f7b5f8ec.tar.gz
gentoo-2-7df4e493715ec4a011c5767bb2fdb0e9f7b5f8ec.tar.bz2
gentoo-2-7df4e493715ec4a011c5767bb2fdb0e9f7b5f8ec.zip
Adding 2.14 series, to go along with glib-2.14 for Gnome 2.20
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-python/pygobject')
-rw-r--r--dev-python/pygobject/ChangeLog7
-rw-r--r--dev-python/pygobject/files/digest-pygobject-2.14.03
-rw-r--r--dev-python/pygobject/pygobject-2.14.0.ebuild75
3 files changed, 84 insertions, 1 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index f254f7695ee2..32a52258c987 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.22 2007/07/26 21:32:44 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.23 2007/09/26 13:15:05 leio Exp $
+
+*pygobject-2.14.0 (26 Sep 2007)
+
+ 26 Sep 2007; Mart Raudsepp <leio@gentoo.org> +pygobject-2.14.0.ebuild:
+ Adding 2.14 series, to go along with glib-2.14 for Gnome 2.20
26 Jul 2007; Roy Marples <uberlord@gentoo.org> pygobject-2.12.3.ebuild:
true is not always in /bin
diff --git a/dev-python/pygobject/files/digest-pygobject-2.14.0 b/dev-python/pygobject/files/digest-pygobject-2.14.0
new file mode 100644
index 000000000000..0192ff4bbc8b
--- /dev/null
+++ b/dev-python/pygobject/files/digest-pygobject-2.14.0
@@ -0,0 +1,3 @@
+MD5 de781a21f483c941a73009a9f68f150e pygobject-2.14.0.tar.bz2 360630
+RMD160 71702329535680a813a36e05823d1968cb453b25 pygobject-2.14.0.tar.bz2 360630
+SHA256 3a5919703f71c2d7059d02f03dc6566cbe86c6efb09a16730b7cdb4b0fbef9e8 pygobject-2.14.0.tar.bz2 360630
diff --git a/dev-python/pygobject/pygobject-2.14.0.ebuild b/dev-python/pygobject/pygobject-2.14.0.ebuild
new file mode 100644
index 000000000000..271f83091ee1
--- /dev/null
+++ b/dev-python/pygobject/pygobject-2.14.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.0.ebuild,v 1.1 2007/09/26 13:15:05 leio Exp $
+
+WANT_AUTOCONF=none
+WANT_AUTOMAKE=1.8
+inherit gnome2 python autotools
+
+DESCRIPTION="GLib's GObject library bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+# FIXME: add libffi dependency ?
+
+# glib higher dep than in configure.in comes from a runtime version check and ensures that
+# timeout_add_seconds is available for any packages that depend on pygobject and use it
+# python high dep for a fixed python-config, as aclocal.m4/configure in the tarball requires it to function properly
+RDEPEND=">=dev-lang/python-2.4.4-r5
+ >=dev-libs/glib-2.13.5
+ !<dev-python/pygtk-2.9"
+DEPEND="${RDEPEND}
+ doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS ChangeLog INSTALL NEWS README"
+
+pkg_setup() {
+ G2CONF="$(use_enable doc docs)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fix bug #147285 - Robin H. Johnson <robbat2@gentoo.org>
+ # this is caused by upstream's automake-1.8 lacking some Gentoo-specific
+ # patches (for tmpfs amongst other things). Upstreams hit by this should
+ # move to newer automake versions ideally.
+ eautomake
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${P}
+ doins -r examples
+ fi
+
+ python_version
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py-2.0
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth-2.0
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/gtk-2.0
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+ python_mod_compile ${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}