summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2007-10-14 23:14:48 +0000
committerRob Cakebread <pythonhead@gentoo.org>2007-10-14 23:14:48 +0000
commit409037750a30f8f12aa15a5d20f02ded67d3f31a (patch)
treeeb0e92427a4572f01f2c8d11e051b3e8137219bc /dev-python/pygments
parentMarked ~hppa (bug #195682). (diff)
downloadgentoo-2-409037750a30f8f12aa15a5d20f02ded67d3f31a.tar.gz
gentoo-2-409037750a30f8f12aa15a5d20f02ded67d3f31a.tar.bz2
gentoo-2-409037750a30f8f12aa15a5d20f02ded67d3f31a.zip
Version bump. Removed superfluous PYTHON_MODULE
(Portage version: 2.1.3.12)
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/ChangeLog8
-rw-r--r--dev-python/pygments/files/digest-pygments-0.93
-rw-r--r--dev-python/pygments/pygments-0.8.1.ebuild9
-rw-r--r--dev-python/pygments/pygments-0.9.ebuild36
4 files changed, 50 insertions, 6 deletions
diff --git a/dev-python/pygments/ChangeLog b/dev-python/pygments/ChangeLog
index 99a3faea88f5..f5094988e126 100644
--- a/dev-python/pygments/ChangeLog
+++ b/dev-python/pygments/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygments
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygments/ChangeLog,v 1.5 2007/06/28 04:15:22 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygments/ChangeLog,v 1.6 2007/10/14 23:14:47 pythonhead Exp $
+
+*pygments-0.9 (14 Oct 2007)
+
+ 14 Oct 2007; Rob Cakebread <pythonhead@gentoo.org> pygments-0.8.1.ebuild,
+ +pygments-0.9.ebuild:
+ Version bump. Removed superfluous PYTHON_MODULE
*pygments-0.8.1 (28 Jun 2007)
diff --git a/dev-python/pygments/files/digest-pygments-0.9 b/dev-python/pygments/files/digest-pygments-0.9
new file mode 100644
index 000000000000..c84df0cacdb9
--- /dev/null
+++ b/dev-python/pygments/files/digest-pygments-0.9
@@ -0,0 +1,3 @@
+MD5 8cdce901a66c0febb576955e90814485 Pygments-0.9.tar.gz 780966
+RMD160 17d1e3ca9a2986593c773a1b66cb5eae4032c6cf Pygments-0.9.tar.gz 780966
+SHA256 5013074493a2df39024b1367b2e1184a5eb2306bdb57cd2098f89d0fd32912b9 Pygments-0.9.tar.gz 780966
diff --git a/dev-python/pygments/pygments-0.8.1.ebuild b/dev-python/pygments/pygments-0.8.1.ebuild
index e3e20adf6414..ac082e91bffa 100644
--- a/dev-python/pygments/pygments-0.8.1.ebuild
+++ b/dev-python/pygments/pygments-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygments/pygments-0.8.1.ebuild,v 1.1 2007/06/28 04:15:22 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygments/pygments-0.8.1.ebuild,v 1.2 2007/10/14 23:14:47 pythonhead Exp $
inherit eutils distutils
@@ -16,15 +16,14 @@ KEYWORDS="~amd64 ~ppc64 ~x86"
SLOT="0"
IUSE="doc"
S=${WORKDIR}/${MY_P}
-PYTHON_MODNAME="pygments"
DOCS="CHANGES"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
#Gentoo patches to make lexer recognize ebuilds as bash input
- epatch ${FILESDIR}/${PN}-0.8-other.py-ebuild.patch || die "Patch failed"
- epatch ${FILESDIR}/${PN}-0.8-_mapping.py-ebuild.patch || die "Patch failed"
+ epatch "${FILESDIR}/${PN}-0.8-other.py-ebuild.patch" || die "Patch failed"
+ epatch "${FILESDIR}/${PN}-0.8-_mapping.py-ebuild.patch" || die "Patch failed"
}
src_install(){
diff --git a/dev-python/pygments/pygments-0.9.ebuild b/dev-python/pygments/pygments-0.9.ebuild
new file mode 100644
index 000000000000..364c3d409526
--- /dev/null
+++ b/dev-python/pygments/pygments-0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygments/pygments-0.9.ebuild,v 1.1 2007/10/14 23:14:47 pythonhead Exp $
+
+inherit eutils distutils
+
+MY_PN="Pygments"
+MY_P="${MY_PN}-${PV}"
+NEED_PYTHON=2.3
+
+DESCRIPTION="Pygments is a syntax highlighting package written in Python."
+HOMEPAGE="http://pygments.org/"
+SRC_URI="http://cheeseshop.python.org/packages/source/P/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+SLOT="0"
+IUSE="doc"
+S=${WORKDIR}/${MY_P}
+DOCS="CHANGES"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #Gentoo patches to make lexer recognize ebuilds as bash input
+ epatch "${FILESDIR}/${PN}-0.8-other.py-ebuild.patch" || die "Patch failed"
+ epatch "${FILESDIR}/${PN}-0.8-_mapping.py-ebuild.patch" || die "Patch failed"
+}
+
+src_install(){
+ distutils_src_install
+ use doc && dohtml -r docs/build/
+}
+
+src_test() {
+ PYTHONPATH=. "${python}" tests/run.py || die "tests failed"
+}