summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-10-08 21:29:03 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-10-08 21:29:03 +0000
commit2782836083e8033d59e9df32bfb7efd1bd43d38d (patch)
tree7b43f5ccafec96afca5c750cc63c8b64a73914f0 /dev-python/pygame
parentzapping fixed. (diff)
downloadgentoo-2-2782836083e8033d59e9df32bfb7efd1bd43d38d.tar.gz
gentoo-2-2782836083e8033d59e9df32bfb7efd1bd43d38d.tar.bz2
gentoo-2-2782836083e8033d59e9df32bfb7efd1bd43d38d.zip
added sdl-ttf and pygame
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/files/digest-pygame-1.21
-rw-r--r--dev-python/pygame/pygame-1.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pygame/files/digest-pygame-1.2 b/dev-python/pygame/files/digest-pygame-1.2
new file mode 100644
index 000000000000..4511652d1d0a
--- /dev/null
+++ b/dev-python/pygame/files/digest-pygame-1.2
@@ -0,0 +1 @@
+MD5 8b7aa16f9dbee0c8cdc064a28bd9b3d3 pygame-1.2.tar.gz
diff --git a/dev-python/pygame/pygame-1.2.ebuild b/dev-python/pygame/pygame-1.2.ebuild
new file mode 100644
index 000000000000..5758294be333
--- /dev/null
+++ b/dev-python/pygame/pygame-1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author David Creswick <davidc@sat.net>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
+SRC_URI="http://www.pygame.org/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.pygame.org/"
+
+#build-time dependencies
+DEPEND="virtual/python
+ >=media-libs/libsdl-1.2.0
+ >=media-libs/sdl-ttf-2.0.3
+ >=media-libs/sdl-image-1.2.0
+ >=media-libs/sdl-mixer-1.2.0
+ >=dev-python/Numeric-19.0.0
+ >=media-libs/smpeg-0.4.4-r1"
+
+src_compile() {
+ python setup.py build || die
+}
+
+src_install () {
+ python setup.py install --prefix=${D}/usr || die
+
+ dodoc README.TXT WHATSNEW
+ dodir /usr/share/doc/${P}/html/
+ cp -a docs/* ${D}/usr/share/doc/${P}/html/
+ cp -a examples ${D}/usr/share/doc/${P}/
+}
+