summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-08-03 23:48:32 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-08-03 23:48:32 +0000
commitaee7b1a751cc587048b6313c1f1b31ae1e191ebe (patch)
tree655a69a2f96b994ebdb218a1ff3905da955c3117 /dev-python/pyface
parentInitial import (diff)
downloadgentoo-2-aee7b1a751cc587048b6313c1f1b31ae1e191ebe.tar.gz
gentoo-2-aee7b1a751cc587048b6313c1f1b31ae1e191ebe.tar.bz2
gentoo-2-aee7b1a751cc587048b6313c1f1b31ae1e191ebe.zip
Initial import
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyface')
-rw-r--r--dev-python/pyface/ChangeLog10
-rw-r--r--dev-python/pyface/metadata.xml16
-rw-r--r--dev-python/pyface/pyface-4.0.0.ebuild64
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/pyface/ChangeLog b/dev-python/pyface/ChangeLog
new file mode 100644
index 000000000000..06d7595419b9
--- /dev/null
+++ b/dev-python/pyface/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pyface
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyface/ChangeLog,v 1.1 2011/08/03 23:48:32 bicatali Exp $
+
+*pyface-4.0.0 (03 Aug 2011)
+
+ 03 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> +pyface-4.0.0.ebuild,
+ +metadata.xml:
+ Initial import
+
diff --git a/dev-python/pyface/metadata.xml b/dev-python/pyface/metadata.xml
new file mode 100644
index 000000000000..73168f8a37eb
--- /dev/null
+++ b/dev-python/pyface/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription lang="en">
+ The pyface project contains a toolkit-independent GUI abstraction
+ layer, which is used to support the "visualization" features of the
+ Traits package. Thus, you can write code in terms of the Traits API
+ (views, items, editors, etc.), and let pyface and your selected
+ toolkit and back-end take care of the details of displaying them.
+ The following GUI backends are supported:
+ * wxPython
+ * PyQt
+ * PySide
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pyface/pyface-4.0.0.ebuild b/dev-python/pyface/pyface-4.0.0.ebuild
new file mode 100644
index 000000000000..c78fe496201a
--- /dev/null
+++ b/dev-python/pyface/pyface-4.0.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyface/pyface-4.0.0.ebuild,v 1.1 2011/08/03 23:48:32 bicatali Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: traits-capable windowing framework"
+HOMEPAGE="https://github.com/enthought/pyface http://pypi.python.org/pypi/pyface"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/traits-4.0
+ || ( dev-python/wxpython dev-python/PyQt4 dev-python/pyside )"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+
+DOCS="docs/*.txt"
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ if use doc; then
+ pushd docs/build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}