summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-31 23:19:42 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-31 23:19:42 +0000
commit37ce3c6e1857590bddf75d12d31f02ad92c31276 (patch)
tree48a8b7873fbbd759e69a76511b6725c81bf6fd32 /dev-python/pyelemental/pyelemental-1.2.0.ebuild
parentRemove old ebuilds and files (diff)
downloadgentoo-2-37ce3c6e1857590bddf75d12d31f02ad92c31276.tar.gz
gentoo-2-37ce3c6e1857590bddf75d12d31f02ad92c31276.tar.bz2
gentoo-2-37ce3c6e1857590bddf75d12d31f02ad92c31276.zip
Update EAPI. Fix dependencies. Set SUPPORT_PYTHON_ABIS.
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyelemental/pyelemental-1.2.0.ebuild')
-rw-r--r--dev-python/pyelemental/pyelemental-1.2.0.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/pyelemental/pyelemental-1.2.0.ebuild b/dev-python/pyelemental/pyelemental-1.2.0.ebuild
index 8f38113b5d03..eff40e8b8298 100644
--- a/dev-python/pyelemental/pyelemental-1.2.0.ebuild
+++ b/dev-python/pyelemental/pyelemental-1.2.0.ebuild
@@ -1,10 +1,15 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyelemental/pyelemental-1.2.0.ebuild,v 1.2 2008/03/20 19:59:48 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyelemental/pyelemental-1.2.0.ebuild,v 1.3 2010/10/31 23:19:42 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
-DESCRIPTION="python bindings for libelemental (sci-chemistry/gelemental)"
+DESCRIPTION="Python bindings for libelemental (sci-chemistry/gelemental)"
HOMEPAGE="http://www.kdau.com/projects/gelemental"
SRC_URI="http://www.kdau.com/files/${P}.tar.bz2"
@@ -21,5 +26,5 @@ DOCS="AUTHORS NEWS"
src_install() {
distutils_src_install
- dohtml docs/html/*.html
+ dohtml docs/html/*.html || die "dohtml failed"
}