summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-09-12 13:55:31 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-09-12 13:55:31 +0000
commit2a12b425f8655a50e9b1549c2d8337a330f91aa9 (patch)
treeaaa9e2b9719af59bc61337af7373baa78484b346 /dev-python/pydns
parentalpha/ia64 stable wrt #236723 (diff)
downloadgentoo-2-2a12b425f8655a50e9b1549c2d8337a330f91aa9.tar.gz
gentoo-2-2a12b425f8655a50e9b1549c2d8337a330f91aa9.tar.bz2
gentoo-2-2a12b425f8655a50e9b1549c2d8337a330f91aa9.zip
version bump, solving bug #233217.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-python/pydns')
-rw-r--r--dev-python/pydns/ChangeLog7
-rw-r--r--dev-python/pydns/pydns-2.3.3.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/pydns/ChangeLog b/dev-python/pydns/ChangeLog
index 053818025f0e..6173444d2021 100644
--- a/dev-python/pydns/ChangeLog
+++ b/dev-python/pydns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pydns
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pydns/ChangeLog,v 1.2 2008/04/07 00:08:48 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydns/ChangeLog,v 1.3 2008/09/12 13:55:31 sbriesen Exp $
+
+*pydns-2.3.3 (12 Sep 2008)
+
+ 12 Sep 2008; Stefan Briesenick <sbriesen@gentoo.org> +pydns-2.3.3.ebuild:
+ version bump, solving bug #233217.
*pydns-2.3.1 (07 Apr 2008)
diff --git a/dev-python/pydns/pydns-2.3.3.ebuild b/dev-python/pydns/pydns-2.3.3.ebuild
new file mode 100644
index 000000000000..7bb34c4206a6
--- /dev/null
+++ b/dev-python/pydns/pydns-2.3.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydns/pydns-2.3.3.ebuild,v 1.1 2008/09/12 13:55:31 sbriesen Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Python module for DNS (Domain Name Service)"
+HOMEPAGE="http://pydns.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pydns/${P}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="virtual/python"
+DEPEND="${RDEPEND}
+ virtual/libiconv"
+
+PYTHON_MODNAME="DNS"
+DOCS="CREDITS.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix encodings (should be utf-8 but is latin1)
+ for i in CREDITS.txt "${PYTHON_MODNAME}"/{Lib,Type}.py; do
+ iconv -f ISO-8859-1 -t UTF-8 < "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+
+ # fix setup.cfg (do not compile bytecode!)
+ sed -i -e 's:^\(compile\).*:\1 = 0:g' -e 's:^\(optimize\).*:\1 = 0:g' setup.cfg
+
+ # fix python path in examples
+ sed -i -e 's:#!/.*\(python\)/*$:#!/usr/bin/\1:g' {tests,tools}/*.py
+}
+
+src_install(){
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/*.py tools/*.py
+ fi
+}