summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2011-12-24 13:21:05 +0000
committerAndrey Grozin <grozin@gentoo.org>2011-12-24 13:21:05 +0000
commit2602854acb8a8469083994651ca3b589ccda1ebd (patch)
treee04c606f2bd8d475354d1b8d1b26020d82be90ba /dev-python/pydb/pydb-1.26.ebuild
parentRevision bump. Adds patch for rpath, thanks to Alphat-PC <AlphatPC@gmail.com>... (diff)
downloadgentoo-2-2602854acb8a8469083994651ca3b589ccda1ebd.tar.gz
gentoo-2-2602854acb8a8469083994651ca3b589ccda1ebd.tar.bz2
gentoo-2-2602854acb8a8469083994651ca3b589ccda1ebd.zip
Bug #379193 fixed, thanks to Ulrich Müller <ulm@gentoo.org>
(Portage version: 2.2.0_alpha81/cvs/Linux i686)
Diffstat (limited to 'dev-python/pydb/pydb-1.26.ebuild')
-rw-r--r--dev-python/pydb/pydb-1.26.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/dev-python/pydb/pydb-1.26.ebuild b/dev-python/pydb/pydb-1.26.ebuild
index c5e72775da14..3322291de7d7 100644
--- a/dev-python/pydb/pydb-1.26.ebuild
+++ b/dev-python/pydb/pydb-1.26.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pydb/pydb-1.26.ebuild,v 1.2 2009/04/18 21:27:42 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydb/pydb-1.26.ebuild,v 1.3 2011/12/24 13:21:05 grozin Exp $
+
+EAPI=3
+
+inherit elisp-common
DESCRIPTION="Extended python debugger"
HOMEPAGE="http://bashdb.sourceforge.net/pydb/"
@@ -8,19 +12,22 @@ SRC_URI="mirror://sourceforge/bashdb/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-
-# emacs support could be made optional with some extra work
-# sorry, I was too lazy
-IUSE=""
+IUSE="emacs"
DEPEND=">=dev-lang/python-2.4.0
- >=app-editors/emacs-22.0"
+ virtual/emacs"
+RDEPEND="${DEPEND}"
# This package uses not distutils but the usual
# ./configure; make; make install
# The default src_compile is OK
+src_configure() {
+ econf --with-lispdir="${SITELISP}/${PN}" \
+ EMACS="$(use emacs && echo "${EMACS}" || echo no)"
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
}