summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-09 13:11:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-09 13:11:43 +0000
commit0069356b5fb9259afe7b2423ec0a844638f14132 (patch)
tree420768eaeaaa22cda905eae8a229c107fbc374c1 /dev-python/pycxx
parentBump to latest upstream patches (diff)
downloadgentoo-2-0069356b5fb9259afe7b2423ec0a844638f14132.tar.gz
gentoo-2-0069356b5fb9259afe7b2423ec0a844638f14132.tar.bz2
gentoo-2-0069356b5fb9259afe7b2423ec0a844638f14132.zip
Reorganize patches.
(Portage version: 2.2.0_alpha26_p10/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/files/pycxx-6.2.3-installation.patch19
-rw-r--r--dev-python/pycxx/files/pycxx-6.2.3-python-3.patch33
-rw-r--r--dev-python/pycxx/pycxx-6.2.3.ebuild6
3 files changed, 55 insertions, 3 deletions
diff --git a/dev-python/pycxx/files/pycxx-6.2.3-installation.patch b/dev-python/pycxx/files/pycxx-6.2.3-installation.patch
new file mode 100644
index 000000000000..cd7523ccdecd
--- /dev/null
+++ b/dev-python/pycxx/files/pycxx-6.2.3-installation.patch
@@ -0,0 +1,19 @@
+--- setup.py
++++ setup.py
+@@ -3,10 +3,12 @@
+ from distutils.command.install import install
+ from distutils.core import setup
+
+-headers = (glob( os.path.join( "CXX","*.hxx" ) )
+- +glob( os.path.join( "CXX","*.h" ) ))
+-sources = (glob( os.path.join( "Src", "*.cxx" ) )
+- +glob( os.path.join( "Src", "*.c" ) ))
++headers = (glob( os.path.join( "CXX", "Python%s" % sys.version_info[0], "*.hxx" ) )
++ +glob( os.path.join( "CXX", "Python%s" % sys.version_info[0], "*.h" ) )
++ +[os.path.join( "CXX", "Version.hxx" )]
++ +[os.path.join( "CXX", "WrapPython.h" )])
++sources = (glob( os.path.join( "Src", "Python%s" % sys.version_info[0], "*.cxx" ) )
++ +glob( os.path.join( "Src", "Python%s" % sys.version_info[0], "*.c" ) ))
+
+
+ class my_install (install):
diff --git a/dev-python/pycxx/files/pycxx-6.2.3-python-3.patch b/dev-python/pycxx/files/pycxx-6.2.3-python-3.patch
new file mode 100644
index 000000000000..c5d6ac0f4d0f
--- /dev/null
+++ b/dev-python/pycxx/files/pycxx-6.2.3-python-3.patch
@@ -0,0 +1,33 @@
+--- Lib/__init__.py
++++ Lib/__init__.py
+@@ -34,8 +34,8 @@
+ # DAMAGE.
+ #
+ #-----------------------------------------------------------------------------
+-print """CXX is installed.
++print("""CXX is installed.
+ The support files you need are in the PYTHON/etc/CXX directory.
+ The include files are in the distutils include path already.
+ Just refer to them as "CXX/CXX_Objects.h", etc.
+-"""
++""")
+--- setup.py
++++ setup.py
+@@ -12,13 +12,13 @@
+ class my_install (install):
+
+ def finalize_options (self):
+- if not self.install_data or (len(self.install_data) < 8) :
+- self.install_data = "$base/share/python$py_version_short"
++ if not self.install_data or (len(self.install_data) < 8) :
++ self.install_data = "$base/share/python$py_version_short"
+ install.finalize_options (self)
+
+ def run (self):
+- self.distribution.data_files = [("CXX", sources)]
+- self.distribution.headers = headers
++ self.distribution.data_files = [("CXX", sources)]
++ self.distribution.headers = headers
+ install.run (self)
+
+
diff --git a/dev-python/pycxx/pycxx-6.2.3.ebuild b/dev-python/pycxx/pycxx-6.2.3.ebuild
index 889f64264e46..e26687b94c28 100644
--- a/dev-python/pycxx/pycxx-6.2.3.ebuild
+++ b/dev-python/pycxx/pycxx-6.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.2.3.ebuild,v 1.1 2011/03/07 23:00:39 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.2.3.ebuild,v 1.2 2011/03/09 13:11:43 arfrever Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
@@ -20,8 +20,8 @@ IUSE="doc examples"
PYTHON_MODNAME="CXX"
src_prepare() {
- epatch "${FILESDIR}/${PN}-6.1.0-setup.py.patch"
- epatch "${FILESDIR}/${PN}-6.1.0-python-3.patch"
+ epatch "${FILESDIR}/${P}-python-3.patch"
+ epatch "${FILESDIR}/${P}-installation.patch"
epatch "${FILESDIR}/${PN}-6.1.0-C_compatible_headers.patch"
sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"