summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-03-11 00:56:01 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-03-11 00:56:01 +0000
commitd74a8088052ecbbcf1ee27bff52604a3e2093cc5 (patch)
tree657b505ccf7667c290a079c8ee37352692239dd4 /dev-python/pycups/pycups-1.9.49.ebuild
parentFix (detection and) building with libpng14. (diff)
downloadgentoo-2-d74a8088052ecbbcf1ee27bff52604a3e2093cc5.tar.gz
gentoo-2-d74a8088052ecbbcf1ee27bff52604a3e2093cc5.tar.bz2
gentoo-2-d74a8088052ecbbcf1ee27bff52604a3e2093cc5.zip
Version bump 1.9.49, remove old versions
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycups/pycups-1.9.49.ebuild')
-rw-r--r--dev-python/pycups/pycups-1.9.49.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pycups/pycups-1.9.49.ebuild b/dev-python/pycups/pycups-1.9.49.ebuild
new file mode 100644
index 000000000000..83e23cc6d6c6
--- /dev/null
+++ b/dev-python/pycups/pycups-1.9.49.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/pycups-1.9.49.ebuild,v 1.1 2010/03/11 00:56:01 reavertm Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2:2.4"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils flag-o-matic
+
+DESCRIPTION="Python bindings for the CUPS API"
+HOMEPAGE="http://cyberelk.net/tim/data/pycups/"
+SRC_URI="http://cyberelk.net/tim/data/pycups/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ net-print/cups
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/epydoc )
+"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_compile() {
+ append-cflags -DVERSION=\\\"${PV}\\\"
+ distutils_src_compile
+
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r html/ || die "installing html docs failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/"${P}"
+ doins -r examples/ || die "installing examples failed"
+ fi
+
+}