summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2010-11-28 20:42:58 +0000
committerMichael Januszewski <spock@gentoo.org>2010-11-28 20:42:58 +0000
commit2754a1dd152e0071d5f9ce1f5ca1f936bca182f8 (patch)
treee606714402bdf8f1901cfc0b403999f406d393b2 /dev-python/pycuda
parentAdd a fix for bug #346339. (diff)
downloadgentoo-2-2754a1dd152e0071d5f9ce1f5ca1f936bca182f8.tar.gz
gentoo-2-2754a1dd152e0071d5f9ce1f5ca1f936bca182f8.tar.bz2
gentoo-2-2754a1dd152e0071d5f9ce1f5ca1f936bca182f8.zip
Version bump (bug #341531).
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycuda')
-rw-r--r--dev-python/pycuda/ChangeLog7
-rw-r--r--dev-python/pycuda/pycuda-0.94.2.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/pycuda/ChangeLog b/dev-python/pycuda/ChangeLog
index 1d1852b9c6ae..9cec37b70ce0 100644
--- a/dev-python/pycuda/ChangeLog
+++ b/dev-python/pycuda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycuda
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/ChangeLog,v 1.6 2010/02/08 17:24:43 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/ChangeLog,v 1.7 2010/11/28 20:42:58 spock Exp $
+
+*pycuda-0.94.2 (28 Nov 2010)
+
+ 28 Nov 2010; Michał Januszewski <spock@gentoo.org> +pycuda-0.94.2.ebuild:
+ Version bump (bug #341531).
08 Feb 2010; Michał Januszewski <spock@gentoo.org> pycuda-0.93.ebuild,
pycuda-9999.ebuild:
diff --git a/dev-python/pycuda/pycuda-0.94.2.ebuild b/dev-python/pycuda/pycuda-0.94.2.ebuild
new file mode 100644
index 000000000000..b509eae94c1f
--- /dev/null
+++ b/dev-python/pycuda/pycuda-0.94.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-0.94.2.ebuild,v 1.1 2010/11/28 20:42:58 spock Exp $
+
+EAPI="2"
+
+inherit distutils eutils
+
+DESCRIPTION="Python wrapper for NVIDIA CUDA"
+HOMEPAGE="http://mathema.tician.de/software/pycuda http://pypi.python.org/pypi/pycuda"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl"
+
+RDEPEND="dev-python/decorator
+ dev-python/pytools
+ dev-libs/boost[python]
+ >=dev-util/nvidia-cuda-toolkit-2.0
+ >=dev-python/numpy-1.0.4
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+src_configure()
+{
+ local myopts=""
+ use opengl && myopts="${myopts} --cuda-enable-gl"
+
+ ./configure.py --cuda-root="${ROOT}opt/cuda" \
+ --boost-python-libname=boost_python-mt \
+ --boost-thread-libname=boost_thread-mt \
+ ${myopts}
+}
+
+src_install()
+{
+ distutils_src_install
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ doins -r examples || die
+ fi
+}
+
+pkg_postinst()
+{
+ distutils_pkg_postinst
+ if use examples; then
+ elog "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+}