summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-11-19 20:24:53 +0000
committerMike Gilbert <floppym@gentoo.org>2012-11-19 20:24:53 +0000
commit51da760c5997139b3cb0ee8747cbe11673301ec7 (patch)
tree7121830713f906db7afba6173afe142e1caaaa39 /dev-python/pycrypto
parentAdd swig to DEPEND since upstream requires it #434660 by BT. (diff)
downloadgentoo-2-51da760c5997139b3cb0ee8747cbe11673301ec7.tar.gz
gentoo-2-51da760c5997139b3cb0ee8747cbe11673301ec7.tar.bz2
gentoo-2-51da760c5997139b3cb0ee8747cbe11673301ec7.zip
Unrestrict python 3.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/pycrypto')
-rw-r--r--dev-python/pycrypto/ChangeLog7
-rw-r--r--dev-python/pycrypto/pycrypto-2.6-r1.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/pycrypto/ChangeLog b/dev-python/pycrypto/ChangeLog
index 12537c02f9bb..8535ddd0be06 100644
--- a/dev-python/pycrypto/ChangeLog
+++ b/dev-python/pycrypto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycrypto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycrypto/ChangeLog,v 1.126 2012/08/01 19:17:31 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycrypto/ChangeLog,v 1.127 2012/11/19 20:24:53 floppym Exp $
+
+*pycrypto-2.6-r1 (19 Nov 2012)
+
+ 19 Nov 2012; Mike Gilbert <floppym@gentoo.org> +pycrypto-2.6-r1.ebuild:
+ Unrestrict python 3.
01 Aug 2012; Ulrich Müller <ulm@gentoo.org> pycrypto-2.6.ebuild:
Add ~amd64-fbsd keyword, with permission from ryao.
diff --git a/dev-python/pycrypto/pycrypto-2.6-r1.ebuild b/dev-python/pycrypto/pycrypto-2.6-r1.ebuild
new file mode 100644
index 000000000000..5ff7bcca9173
--- /dev/null
+++ b/dev-python/pycrypto/pycrypto-2.6-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycrypto/pycrypto-2.6-r1.ebuild,v 1.1 2012/11/19 20:24:53 floppym Exp $
+
+EAPI="4"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Python Cryptography Toolkit"
+HOMEPAGE="http://www.dlitz.net/software/pycrypto/ http://pypi.python.org/pypi/pycrypto"
+SRC_URI="http://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/${P}.tar.gz"
+
+LICENSE="PSF-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc +gmp"
+
+RDEPEND="gmp? ( dev-libs/gmp )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/docutils >=dev-python/epydoc-3 )"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="ACKS ChangeLog README TODO"
+PYTHON_MODNAME="Crypto"
+
+src_configure() {
+ econf \
+ $(use_with gmp) \
+ --without-mpir
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ rst2html.py Doc/pycrypt.rst > Doc/index.html
+ PYTHONPATH="$(ls -d build-$(PYTHON --ABI -f)/lib.*)" epydoc --config=Doc/epydoc-config --exclude-introspect="^Crypto\.(Random\.OSRNG\.nt|Util\.winrandom)$" || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml Doc/apidoc/* Doc/index.html
+ fi
+}