summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-05-14 19:28:15 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-05-14 19:28:15 +0000
commit86ded425329bac3b27257781c713db77c7be8075 (patch)
treee79e5024c6fc2efef9712a1d4560d7e2e2ed66e8 /dev-python/pychef
parentrevbump; migrate -> distutils-r1, corrections to all deps in dep list, drop o... (diff)
downloadgentoo-2-86ded425329bac3b27257781c713db77c7be8075.tar.gz
gentoo-2-86ded425329bac3b27257781c713db77c7be8075.tar.bz2
gentoo-2-86ded425329bac3b27257781c713db77c7be8075.zip
initial commit of PyChef (dev-python/pychef)
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/pychef')
-rw-r--r--dev-python/pychef/ChangeLog9
-rw-r--r--dev-python/pychef/Manifest3
-rw-r--r--dev-python/pychef/metadata.xml13
-rw-r--r--dev-python/pychef/pychef-0.2.1.ebuild28
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pychef/ChangeLog b/dev-python/pychef/ChangeLog
new file mode 100644
index 000000000000..e8fba74f2e34
--- /dev/null
+++ b/dev-python/pychef/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/pychef
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pychef/ChangeLog,v 1.1 2013/05/14 19:28:15 prometheanfire Exp $
+
+*pychef-0.2.1 (14 May 2013)
+
+ 14 May 2013; Matthew Thode <prometheanfire@gentoo.org> +metadata.xml,
+ +pychef-0.2.1.ebuild:
+ initial commit of PyChef (dev-python/pychef)
diff --git a/dev-python/pychef/Manifest b/dev-python/pychef/Manifest
new file mode 100644
index 000000000000..e43f2609370c
--- /dev/null
+++ b/dev-python/pychef/Manifest
@@ -0,0 +1,3 @@
+DIST PyChef-0.2.1.tar.gz 29251 SHA256 a74e922eb275a1ea26fc1e65eeb503a610f026f144d6537160f3f380d2108489 SHA512 8d591087c649b5b0d09d4f7b7b26cec56631742833ac7b53eaaa744bd3b42d290ec37df96bdb0ea17a9c824d091d4527458d83abcdf4b2c029f921dbda425220 WHIRLPOOL d271b8991061155b8195e6b90877423ac5363064e9257a1a238b2b3a4f2a389c6b7fa8923ae85ac3f4946fa78e493556ce3fd61945d8bc8f02daa8e0325e994c
+EBUILD pychef-0.2.1.ebuild 782 SHA256 ad1e49aecf9de5653c3302aaa556b5a0d26b733cb21f1941ca3927af2c227eca SHA512 0605aa2584000596b1fe5d5f2d4c37cd350fc9955533c1fb2bd177a0a0ac0598c3eb02244b8143d31ccbb9ebaaad22ea99ac71c587194a6196c54f448b278fb6 WHIRLPOOL cf66eae6598619bc2639a2d528f400733eff344f6f05e92534221c41f77161875fd1c04e65781fb63193b33a9f0a4d769609df73febe9d9ae712f0d9d3c7f121
+MISC metadata.xml 373 SHA256 7175aabcb23ffe54e1ad87be37d7509727266db7e07b01ee768c094b9697d56c SHA512 c842a855d5768098925d1c69d4c957b67f61487772004ee5cef3f305470f3de93301078e7bafdc9d345b436a7d91f7b11360c3b8edceb5001a7a1c70d71a0a44 WHIRLPOOL 2c709a44742b65e560df9b1ed84915c63be78f62d7f69e2f0354060bc9dfa81b76ff4cc6b589d93fdb2c05614853675c64d79459e73bb140043d099bad0f7080
diff --git a/dev-python/pychef/metadata.xml b/dev-python/pychef/metadata.xml
new file mode 100644
index 000000000000..e91b221daa04
--- /dev/null
+++ b/dev-python/pychef/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Python API for interacting with a Chef server.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-python/pychef/pychef-0.2.1.ebuild b/dev-python/pychef/pychef-0.2.1.ebuild
new file mode 100644
index 000000000000..ff9c199e8ce8
--- /dev/null
+++ b/dev-python/pychef/pychef-0.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pychef/pychef-0.2.1.ebuild,v 1.1 2013/05/14 19:28:15 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Nova API"
+HOMEPAGE="https://github.com/coderanger/pychef"
+SRC_URI="mirror://pypi/P/PyChef/PyChef-${PV}.tar.gz"
+S="${WORKDIR}/PyChef-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/versiontools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die
+}