summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-06-30 20:42:34 +0000
committerAli Polatel <hawking@gentoo.org>2007-06-30 20:42:34 +0000
commitd1c037c00e46260b25912411d70f25956b1710f1 (patch)
treeabc05d79ff8f6c408a2bd5bd9febd8365a791847 /dev-python/pycairo
parentUpdate Nero license. (diff)
downloadgentoo-2-d1c037c00e46260b25912411d70f25956b1710f1.tar.gz
gentoo-2-d1c037c00e46260b25912411d70f25956b1710f1.tar.bz2
gentoo-2-d1c037c00e46260b25912411d70f25956b1710f1.zip
Add python_mod_optimize/cleanup wrt bug 177559, cosmetics
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/ChangeLog7
-rw-r--r--dev-python/pycairo/pycairo-1.2.2.ebuild23
-rw-r--r--dev-python/pycairo/pycairo-1.2.6.ebuild23
-rw-r--r--dev-python/pycairo/pycairo-1.4.0.ebuild29
4 files changed, 67 insertions, 15 deletions
diff --git a/dev-python/pycairo/ChangeLog b/dev-python/pycairo/ChangeLog
index 6ce14e6435a8..066c74a97865 100644
--- a/dev-python/pycairo/ChangeLog
+++ b/dev-python/pycairo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycairo
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.40 2007/06/15 22:01:20 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.41 2007/06/30 20:42:34 hawking Exp $
+
+ 30 Jun 2007; Ali Polatel <hawking@gentoo.org> pycairo-1.2.2.ebuild,
+ pycairo-1.2.6.ebuild, pycairo-1.4.0.ebuild:
+ Add python_mod_optimize/cleanup wrt bug 177559, use NEED_PYTHON, add
+ trailing slash to HOMEPAGE
15 Jun 2007; Doug Goldstein <cardoe@gentoo.org> -pycairo-1.0.2.ebuild:
remove old version since cairo 1.0.x is going bye bye
diff --git a/dev-python/pycairo/pycairo-1.2.2.ebuild b/dev-python/pycairo/pycairo-1.2.2.ebuild
index 32ed903cfb7d..a80c616daf96 100644
--- a/dev-python/pycairo/pycairo-1.2.2.ebuild
+++ b/dev-python/pycairo/pycairo-1.2.2.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.2.2.ebuild,v 1.12 2007/01/20 19:24:17 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.2.2.ebuild,v 1.13 2007/06/30 20:42:34 hawking Exp $
+NEED_PYTHON=2.3
WANT_AUTOCONF=latest
WANT_AUTOMAKE=latest
-inherit eutils autotools
+inherit eutils autotools python multilib
DESCRIPTION="Python wrapper for cairo vector graphics library"
-HOMEPAGE="http://cairographics.org/pycairo"
+HOMEPAGE="http://cairographics.org/pycairo/"
SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
@@ -16,8 +17,7 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
IUSE="examples numeric"
-RDEPEND=">=dev-lang/python-2.3
- >=x11-libs/cairo-1.2.0
+RDEPEND=">=x11-libs/cairo-1.2.0
numeric? ( dev-python/numeric )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -26,6 +26,11 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ # don't run py-compile
+ sed -i \
+ -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
+ cairo/Makefile.in || die "sed in cairo/Makefile.in failed"
+
epatch "${FILESDIR}"/${P}-no-automagic-deps.patch
eautoreconf
@@ -49,3 +54,11 @@ src_install() {
dodoc AUTHORS NOTES README NEWS ChangeLog
}
+
+pkg_postinst() {
+ python_mod_optimize ${ROOT}usr/$(get_libdir)/python*/site-packages/cairo
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
diff --git a/dev-python/pycairo/pycairo-1.2.6.ebuild b/dev-python/pycairo/pycairo-1.2.6.ebuild
index 69cc483e46f4..c4369168ca53 100644
--- a/dev-python/pycairo/pycairo-1.2.6.ebuild
+++ b/dev-python/pycairo/pycairo-1.2.6.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.2.6.ebuild,v 1.4 2007/05/27 02:42:43 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.2.6.ebuild,v 1.5 2007/06/30 20:42:34 hawking Exp $
+NEED_PYTHON=2.3
WANT_AUTOCONF=latest
WANT_AUTOMAKE=latest
-inherit eutils autotools
+inherit eutils autotools python multilib
DESCRIPTION="Python wrapper for cairo vector graphics library"
-HOMEPAGE="http://cairographics.org/pycairo"
+HOMEPAGE="http://cairographics.org/pycairo/"
SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
@@ -16,8 +17,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="examples numeric"
-RDEPEND=">=dev-lang/python-2.3
- >=x11-libs/cairo-1.2.6
+RDEPEND=">=x11-libs/cairo-1.2.6
numeric? ( dev-python/numeric )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -26,6 +26,11 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ # don't run py-compile
+ sed -i \
+ -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
+ cairo/Makefile.in || die "sed in cairo/Makefile.in failed"
+
epatch "${FILESDIR}"/${P}-no-automagic-deps.patch
eautoreconf
@@ -49,3 +54,11 @@ src_install() {
dodoc AUTHORS NOTES README NEWS ChangeLog
}
+
+pkg_postinst() {
+ python_mod_optimize ${ROOT}usr/$(get_libdir)/python*/site-packages/cairo
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
diff --git a/dev-python/pycairo/pycairo-1.4.0.ebuild b/dev-python/pycairo/pycairo-1.4.0.ebuild
index 9fd1c1a5bfbb..0f2e65b71d94 100644
--- a/dev-python/pycairo/pycairo-1.4.0.ebuild
+++ b/dev-python/pycairo/pycairo-1.4.0.ebuild
@@ -1,9 +1,13 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.4.0.ebuild,v 1.1 2007/03/14 23:15:56 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.4.0.ebuild,v 1.2 2007/06/30 20:42:34 hawking Exp $
+
+NEED_PYTHON=2.3
+
+inherit python multilib
DESCRIPTION="Python wrapper for cairo vector graphics library"
-HOMEPAGE="http://cairographics.org/pycairo"
+HOMEPAGE="http://cairographics.org/pycairo/"
SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
@@ -11,11 +15,20 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="examples"
-RDEPEND=">=dev-lang/python-2.3
- >=x11-libs/cairo-1.4.0"
+RDEPEND=">=x11-libs/cairo-1.4.0"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # don't run py-compile
+ sed -i \
+ -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
+ cairo/Makefile.in || die "sed in cairo/Makefile.in failed"
+}
+
src_install() {
make DESTDIR="${D}" install || die "install failed"
@@ -27,3 +40,11 @@ src_install() {
dodoc AUTHORS NOTES README NEWS ChangeLog
}
+
+pkg_postinst() {
+ python_mod_optimize ${ROOT}usr/$(get_libdir)/python*/site-packages/cairo
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}