summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2012-11-06 06:10:40 +0000
committerIan Delaney <idella4@gentoo.org>2012-11-06 06:10:40 +0000
commita773e7fe397d2dcbe3bf2e684428c12564eacfd7 (patch)
tree1ff6de454fe22d52256eb69a77597e8ed312182d /dev-python/pycairo
parentRemove duplicate Changelog :/ (diff)
downloadgentoo-2-a773e7fe397d2dcbe3bf2e684428c12564eacfd7.tar.gz
gentoo-2-a773e7fe397d2dcbe3bf2e684428c12564eacfd7.tar.bz2
gentoo-2-a773e7fe397d2dcbe3bf2e684428c12564eacfd7.zip
python 2.4, pypy removed from RESTRICT_PYTHON_ABIS, test phase updated implementing pypy, fixes Bug #420497
(Portage version: 2.1.11.30/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/ChangeLog7
-rw-r--r--dev-python/pycairo/pycairo-1.10.0-r2.ebuild20
2 files changed, 22 insertions, 5 deletions
diff --git a/dev-python/pycairo/ChangeLog b/dev-python/pycairo/ChangeLog
index 885d3eb9b75f..081bb9d47801 100644
--- a/dev-python/pycairo/ChangeLog
+++ b/dev-python/pycairo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pycairo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.110 2012/06/02 11:59:24 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.111 2012/11/06 06:10:40 idella4 Exp $
+
+ 06 Nov 2012; Ian Delaney <idella4@gentoo.org> pycairo-1.10.0-r2.ebuild:
+ python 2.4, pypy removed from RESTRICT_PYTHON_ABIS, test phase updated
+ implementing pypy, fixes Bug #420497
02 Jun 2012; Marien Zwart <marienz@gentoo.org>
-files/pycairo-1.8.10-cairo.version_info.patch, -pycairo-1.10.0-r1.ebuild,
@@ -418,4 +422,3 @@
04 Feb 2005; Fernando Serboncini <fserb@gentoo.org> +metadata.xml,
+pycairo-0.1.4.ebuild:
Initial ebuild
-
diff --git a/dev-python/pycairo/pycairo-1.10.0-r2.ebuild b/dev-python/pycairo/pycairo-1.10.0-r2.ebuild
index 40166a1da61a..dde286c79845 100644
--- a/dev-python/pycairo/pycairo-1.10.0-r2.ebuild
+++ b/dev-python/pycairo/pycairo-1.10.0-r2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.10.0-r2.ebuild,v 1.10 2012/06/02 11:59:24 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.10.0-r2.ebuild,v 1.11 2012/11/06 06:10:40 idella4 Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6 3:3.1"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.0 *-jython *-pypy-*"
+RESTRICT_PYTHON_ABIS="2.5 3.0 *-jython"
inherit eutils python waf-utils
@@ -71,7 +71,21 @@ src_test() {
}
python_execute_function -q -s test_installation
- python_execute_py.test -P '${T}/tests/${PYTHON_ABI}${EPREFIX}$(python_get_sitedir)' -s
+ testing() {
+ # Need a variable for the pypy minor version and a variable to set 2 distinct pythonpaths
+ local pypy_v= PyPath= exit_status=0
+ pypy_v=$(python_get_version)
+ if [[ "${PYTHON_ABI:4:4}" == "pypy" ]]; then
+ PyPath=$(find "${T}"/tests/2.7-pypy-$pypy_v/ -name site-packages)
+ PYTHONPATH="${PyPath}" py.test-${PYTHON_ABI} "${WORKDIR}/${P}-${PYTHON_ABI}"/test || exit_status=1
+ else
+ PyPath="${T}/tests/${PYTHON_ABI}${EPREFIX}"$(python_get_sitedir)
+ PYTHONPATH="${PyPath}" py.test "${WORKDIR}/${P}-${PYTHON_ABI}"/test || exit_status=1
+ fi
+
+ return $exit_status
+ }
+ python_execute_function testing
}
src_install() {