summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-07-04 14:45:06 +0000
committerMarien Zwart <marienz@gentoo.org>2006-07-04 14:45:06 +0000
commit42e988f0822c445ffc6777be541a5371b4ba4222 (patch)
tree9d999f0e5ff37c67088391b9dae7ab8cb812a530 /dev-python/pycairo/files
parentFixed RDEPEND wrt bug #134781 (diff)
downloadgentoo-2-42e988f0822c445ffc6777be541a5371b4ba4222.tar.gz
gentoo-2-42e988f0822c445ffc6777be541a5371b4ba4222.tar.bz2
gentoo-2-42e988f0822c445ffc6777be541a5371b4ba4222.zip
Version bump (in package.mask). Fix automagic dependencies, minor quoting fix.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'dev-python/pycairo/files')
-rw-r--r--dev-python/pycairo/files/digest-pycairo-1.2.03
-rw-r--r--dev-python/pycairo/files/pycairo-1.2.0-no-automagic-deps.patch63
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pycairo/files/digest-pycairo-1.2.0 b/dev-python/pycairo/files/digest-pycairo-1.2.0
new file mode 100644
index 000000000000..4a2ccff334cd
--- /dev/null
+++ b/dev-python/pycairo/files/digest-pycairo-1.2.0
@@ -0,0 +1,3 @@
+MD5 ab531e02fda56a9d6b2b65153fda65f6 pycairo-1.2.0.tar.gz 490529
+RMD160 473fd6abea8dccd6f5c90f7ef1e72ebbd382ec38 pycairo-1.2.0.tar.gz 490529
+SHA256 71b88f540a393d079c671813e8e42d7867d77b6393dd808341a55b3207905504 pycairo-1.2.0.tar.gz 490529
diff --git a/dev-python/pycairo/files/pycairo-1.2.0-no-automagic-deps.patch b/dev-python/pycairo/files/pycairo-1.2.0-no-automagic-deps.patch
new file mode 100644
index 000000000000..ba3b2393e105
--- /dev/null
+++ b/dev-python/pycairo/files/pycairo-1.2.0-no-automagic-deps.patch
@@ -0,0 +1,63 @@
+=== modified file 'configure.ac'
+--- configure.ac
++++ configure.ac
+@@ -33,6 +33,12 @@
+ [AC_HELP_STRING([--with-pygtk], [support pygtk [default=yes]])],
+ [],
+ [with_pygtk="yes"])
++AC_ARG_WITH([svg],
++ AS_HELP_STRING([--without-svg],
++ [Build without libsvg-cairo library (default: test)]))
++AC_ARG_WITH([numeric],
++ AS_HELP_STRING([--without-numeric],
++ [Build without numeric support (default: test)]))
+
+
+ # put the ACLOCAL flags in the makefile
+@@ -77,11 +83,16 @@
+ AM_CONDITIONAL(WITH_PYGTK, test x$with_pygtk = xyes)
+
+ # is libsvg-cairo installed?
+-PKG_CHECK_MODULES(LIBSVG_CAIRO,
+- libsvg-cairo >= libsvg_cairo_required_version,
+- [have_libsvg_cairo=yes],[have_libsvg_cairo=no])
+-if test -n "$export_dynamic"; then
+- LIBSVG_CAIRO_LIBS=`echo $LIBSVG_CAIRO_LIBS | sed -e "s/$export_dynamic//"`
++if test "x$with_svg" != "xno"; then
++ PKG_CHECK_MODULES(LIBSVG_CAIRO,
++ libsvg-cairo >= libsvg_cairo_required_version,
++ [have_libsvg_cairo=yes],[have_libsvg_cairo=no])
++ if test -n "$export_dynamic"; then
++ LIBSVG_CAIRO_LIBS=`echo $LIBSVG_CAIRO_LIBS | sed -e "s/$export_dynamic//"`
++ fi
++else
++ # only needed for the summary printed at the end of configure
++ have_libsvg_cairo=no
+ fi
+ AM_CONDITIONAL(HAVE_LIBSVG_CAIRO, test x$have_libsvg_cairo = xyes)
+
+@@ -89,12 +100,17 @@
+ AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
+
+ # Numeric Python
+-save_CPPFLAGS="$CPPFLAGS"
+-CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
+-AC_CHECK_HEADER([Numeric/arrayobject.h],
+- [have_numpy=yes], [have_numpy=no],
+- [#include <Python.h>])
+-CPPFLAGS="$save_CPPFLAGS"
++if test "x$with_numeric" != "xno"; then
++ save_CPPFLAGS="$CPPFLAGS"
++ CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
++ AC_CHECK_HEADER([Numeric/arrayobject.h],
++ [have_numpy=yes], [have_numpy=no],
++ [#include <Python.h>])
++ CPPFLAGS="$save_CPPFLAGS"
++else
++ # only needed for the summary printed at the end of configure
++ have_numpy=no
++fi
+ if test x$have_numpy = xyes; then
+ AC_DEFINE(HAVE_NUMPY, [1], [Define to 1 if Numeric python is found])
+ fi
+