summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-01 09:24:38 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-01 09:24:38 +0000
commita0498408b4a5c2690cf457b0f9ddc050a0be6fbd (patch)
treec0c94a87e79562d83fd7bb5958cbaaaa2ff923f9 /dev-python/pybluez
parentWhitespace (diff)
downloadgentoo-2-a0498408b4a5c2690cf457b0f9ddc050a0be6fbd.tar.gz
gentoo-2-a0498408b4a5c2690cf457b0f9ddc050a0be6fbd.tar.bz2
gentoo-2-a0498408b4a5c2690cf457b0f9ddc050a0be6fbd.zip
Convert to distutils-r1.
(Portage version: 9999/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/pybluez')
-rw-r--r--dev-python/pybluez/ChangeLog10
-rw-r--r--dev-python/pybluez/pybluez-0.18-r1.ebuild31
2 files changed, 38 insertions, 3 deletions
diff --git a/dev-python/pybluez/ChangeLog b/dev-python/pybluez/ChangeLog
index c86cb5bf31ea..9432204a5561 100644
--- a/dev-python/pybluez/ChangeLog
+++ b/dev-python/pybluez/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pybluez
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pybluez/ChangeLog,v 1.30 2010/07/18 12:37:21 nixnut Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pybluez/ChangeLog,v 1.31 2013/09/01 09:24:38 mgorny Exp $
+
+*pybluez-0.18-r1 (01 Sep 2013)
+
+ 01 Sep 2013; Michał Górny <mgorny@gentoo.org> +pybluez-0.18-r1.ebuild:
+ Convert to distutils-r1.
18 Jul 2010; <nixnut@gentoo.org> pybluez-0.18.ebuild:
ppc stable #317947
@@ -121,4 +126,3 @@
03 Nov 2005; Alastair Tse <liquidx@gentoo.org> +metadata.xml,
+pybluez-0.3.ebuild:
initial commit. ebuil submitted by Philip Kovacs (#95980)
-
diff --git a/dev-python/pybluez/pybluez-0.18-r1.ebuild b/dev-python/pybluez/pybluez-0.18-r1.ebuild
new file mode 100644
index 000000000000..f2adf8d2f105
--- /dev/null
+++ b/dev-python/pybluez/pybluez-0.18-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pybluez/pybluez-0.18-r1.ebuild,v 1.1 2013/09/01 09:24:38 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+MY_P="PyBluez-${PV}"
+
+DESCRIPTION="Python bindings for Bluez Bluetooth Stack"
+HOMEPAGE="http://code.google.com/p/pybluez/"
+SRC_URI="http://pybluez.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DEPEND="net-wireless/bluez"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}